summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-05-24 18:32:29 -0300
committerDaniel Bermond2022-05-24 18:32:29 -0300
commit59924cc03bf1fbccb84ba2450c095972cf154337 (patch)
treed4ff83c193600725e06eccc89d8533126d71c41f
parent66a3a49fbfa1715fe5726ae64603e1e328a0ba60 (diff)
downloadaur-59924cc03bf1fbccb84ba2450c095972cf154337.tar.gz
Update to version 2022.03.24
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4d7aa70491e..18aee4b14a67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = spirv-cross
pkgdesc = A tool and library for parsing and converting SPIR-V to other shader languages
- pkgver = 2021.01.15
- pkgrel = 3
+ pkgver = 2022.03.24
+ pkgrel = 1
url = https://github.com/KhronosGroup/SPIRV-Cross/
arch = x86_64
license = Apache
makedepends = git
makedepends = cmake
makedepends = python
- makedepends = python-nose
depends = gcc-libs
- source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=2021-01-15
- source = git+https://github.com/KhronosGroup/glslang.git#commit=3de5cfe50edecd001e6d703555284d9b10b3dd57
- source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=f3ccb633dfd7c5de1f9f0a2d2e9d7a25f2478206
- source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=f027d53ded7e230e008d37c8b47ede7cd308e19d
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=sdk-1.3.211.0
+ source = git+https://github.com/KhronosGroup/glslang.git#commit=df609a01b386001e367709086c58529c48028d1e
+ source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=75e53b9f685830ac42242cf0c46cc9af523bd0df
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=b8047fbe45f426f5918fadc67e8408f5b108c3c9
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4a7c588ec242..c29573718309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
-_glslang_commit='3de5cfe50edecd001e6d703555284d9b10b3dd57'
-_spirv_tools_commit='f3ccb633dfd7c5de1f9f0a2d2e9d7a25f2478206'
-_spirv_headers_commit='f027d53ded7e230e008d37c8b47ede7cd308e19d'
+_tag='sdk-1.3.211.0'
+_glslang_commit='df609a01b386001e367709086c58529c48028d1e'
+_spirv_tools_commit='75e53b9f685830ac42242cf0c46cc9af523bd0df'
+_spirv_headers_commit='b8047fbe45f426f5918fadc67e8408f5b108c3c9'
pkgname=spirv-cross
-pkgver=2021.01.15
-pkgrel=3
+pkgver=2022.03.24
+pkgrel=1
pkgdesc='A tool and library for parsing and converting SPIR-V to other shader languages'
arch=('x86_64')
url='https://github.com/KhronosGroup/SPIRV-Cross/'
license=('Apache')
depends=('gcc-libs')
-makedepends=('git' 'cmake' 'python' 'python-nose')
-source=("git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=${pkgver//./-}"
+makedepends=('git' 'cmake' 'python')
+source=("git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=${_tag}"
"git+https://github.com/KhronosGroup/glslang.git#commit=${_glslang_commit}"
"git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=${_spirv_tools_commit}"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=${_spirv_headers_commit}")
@@ -30,6 +31,10 @@ prepare() {
ln -sf "${srcdir}/SPIRV-Headers" SPIRV-Tools/external/spirv-headers
}
+pkgver() {
+ git -C SPIRV-Cross log -1 --date='short' --pretty='format:%ci' "$_tag" | awk '{ gsub("-", ".", $1); print $1 }'
+}
+
build() {
# NOTE: test suite fails when using 'None' build type
local -a _common_opts=('-DCMAKE_BUILD_TYPE:STRING=Release' '-Wno-dev')