summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-01-24 15:05:25 -0300
committerDaniel Bermond2022-01-24 15:05:25 -0300
commit66a3a49fbfa1715fe5726ae64603e1e328a0ba60 (patch)
tree6536be24506c6cd70600554f1a8991a4a29b59e6
parent9950d99665b56bbd3c76a42841d4a0b9054f9284 (diff)
downloadaur-66a3a49fbfa1715fe5726ae64603e1e328a0ba60.tar.gz
Handle LTO fat objects
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e734b5a3add..d4d7aa70491e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spirv-cross
pkgdesc = A tool and library for parsing and converting SPIR-V to other shader languages
pkgver = 2021.01.15
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/KhronosGroup/SPIRV-Cross/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index cb427b9c34ad..4a7c588ec242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _spirv_headers_commit='f027d53ded7e230e008d37c8b47ede7cd308e19d'
pkgname=spirv-cross
pkgver=2021.01.15
-pkgrel=2
+pkgrel=3
pkgdesc='A tool and library for parsing and converting SPIR-V to other shader languages'
arch=('x86_64')
url='https://github.com/KhronosGroup/SPIRV-Cross/'
@@ -34,6 +34,9 @@ build() {
# NOTE: test suite fails when using 'None' build type
local -a _common_opts=('-DCMAKE_BUILD_TYPE:STRING=Release' '-Wno-dev')
+ export CFLAGS+=' -ffat-lto-objects'
+ export CXXFLAGS+=' -ffat-lto-objects'
+
# glslang (required for tests)
cmake -B SPIRV-Cross/external/glslang-build -S glslang \
"${_common_opts[@]}" \