summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-23 21:13:02 +0000
committerDaniel Bermond2020-05-23 21:13:02 +0000
commitca398f9fc07665d3345a519d1f8806aadd757534 (patch)
treec4c3c4da0fde88d016240e2b5a4284e8d4c5fbd9
parentc77892d1fb6432a21511f5a4df5464dcc8f2c81b (diff)
downloadaur-ca398f9fc07665d3345a519d1f8806aadd757534.tar.gz
Updated to version 2020.05.19
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43118716c402..a1ffe5089b39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spirv-cross
pkgdesc = A tool and library for parsing and converting SPIR-V to other shader languages
- pkgver = 2020.04.03
+ pkgver = 2020.05.19
pkgrel = 1
url = https://github.com/KhronosGroup/SPIRV-Cross/
arch = x86_64
@@ -10,10 +10,10 @@ pkgbase = spirv-cross
makedepends = python
makedepends = python-nose
depends = gcc-libs
- source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=2020-04-03
- source = git+https://github.com/KhronosGroup/glslang.git#commit=344bd0889ac98c5369df2bf359d0369e3d235b62
- source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=fd773eb50d628c1981338addc093df879757c2cf
- source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=f8bf11a0253a32375c32cad92c841237b96696c0
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git#tag=2020-05-19
+ source = git+https://github.com/KhronosGroup/glslang.git#commit=7d65f09b83112c1ec9e29313cb9913ed2b850aa0
+ source = git+https://github.com/KhronosGroup/SPIRV-Tools.git#commit=67f4838659f475d618c120e13d1a196d7e00ba4b
+ source = git+https://github.com/KhronosGroup/SPIRV-Headers.git#commit=2ad0492fb00919d99500f1da74abf5ad3c870e4e
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 544eb258ea39..02c781b7f518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
-_glslang_commit='344bd0889ac98c5369df2bf359d0369e3d235b62'
-_spirv_tools_commit='fd773eb50d628c1981338addc093df879757c2cf'
-_spirv_headers_commit='f8bf11a0253a32375c32cad92c841237b96696c0'
+_glslang_commit='7d65f09b83112c1ec9e29313cb9913ed2b850aa0'
+_spirv_tools_commit='67f4838659f475d618c120e13d1a196d7e00ba4b'
+_spirv_headers_commit='2ad0492fb00919d99500f1da74abf5ad3c870e4e'
pkgname=spirv-cross
-pkgver=2020.04.03
+pkgver=2020.05.19
pkgrel=1
pkgdesc='A tool and library for parsing and converting SPIR-V to other shader languages'
arch=('x86_64')
@@ -33,9 +33,6 @@ prepare() {
build() {
# NOTE: test suite fails when using 'None' build type
- export CFLAGS+=" ${CPPFLAGS}"
- export CXXFLAGS+=" ${CPPFLAGS}"
-
# glslang (required for tests)
printf '%s\n' ' -> Building glslang...'
cmake -B SPIRV-Cross/external/glslang-build -S glslang \