summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2018-05-20 01:54:10 +0000
committerBalló György2018-05-20 01:54:10 +0000
commitd2b18c35bd1f68bbc6b6b3826c14dcb872087158 (patch)
tree6a346cdfcc1d7383da3e666340418946d456f28c
downloadaur-d2b18c35bd1f68bbc6b6b3826c14dcb872087158.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ef258f4dcc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spivak
+ pkgdesc = Karaoke player based on GStreamer and Qt5
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/gyunaev/spivak
+ arch = x86_64
+ license = GPL3
+ depends = gst-plugins-base
+ depends = libzip
+ depends = qt5-base
+ depends = uchardet
+ source = spivak-1.2.tar.gz::https://github.com/gyunaev/spivak/archive/v1.2.tar.gz
+ sha256sums = 5ea13118d64ffa7206005601fa505b5d06692238091166111edcf7881d94f509
+
+pkgname = spivak
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..978f853eba62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=spivak
+pkgver=1.2
+pkgrel=1
+pkgdesc="Karaoke player based on GStreamer and Qt5"
+arch=(x86_64)
+url="https://github.com/gyunaev/spivak"
+license=(GPL3)
+depends=(gst-plugins-base libzip qt5-base uchardet)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/gyunaev/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('5ea13118d64ffa7206005601fa505b5d06692238091166111edcf7881d94f509')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i '/SUBDIRS += languagedetector/d' plugins/plugins.pro
+}
+
+build() {
+ cd $pkgname-$pkgver
+ qmake
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 src/spivak "$pkgdir/usr/bin/spivak"
+ install -Dm644 packaging/spivak.desktop "$pkgdir/usr/share/applications/spivak.desktop"
+ install -Dm644 packaging/icon.png "$pkgdir/usr/share/pixmaps/spivak.png"
+}