summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-26 09:54:43 -0800
committerJesus Alvarez2017-12-26 09:54:43 -0800
commit7a04eb64ce0af2ed723a370900fd3028b9e8b340 (patch)
treea146dbdabf7ad3dac98ab6d34fc74c02ff296edb
parent3a86523e223a0e02e55b0821114b8855c2ecec0f (diff)
downloadaur-7a04eb64ce0af2ed723a370900fd3028b9e8b340.tar.gz
Semi-automated update for 4.14.8.1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0d0f836c5d4..fbc66299a11d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Fri Dec 22 01:20:17 UTC 2017
+# Mon Dec 25 19:52:52 UTC 2017
pkgbase = spl-linux-git
- pkgver = 2017.12.21.r1060.c9821f1.4.14.7.1
+ pkgver = 2017.12.21.r1060.c9821f1.4.14.8.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-headers=4.14.7-1
+ makedepends = linux-headers=4.14.8-1
makedepends = git
depends = spl-utils-common-git=2017.12.21.r1060.c9821f1
depends = kmod
- depends = linux=4.14.7-1
+ depends = linux=4.14.8-1
source = git+https://github.com/zfsonlinux/spl.git#commit=c9821f1ccc647dfbd506f381b736c664d862d126
sha256sums = SKIP
@@ -25,6 +25,7 @@ pkgname = spl-linux-git
pkgname = spl-linux-git-headers
pkgdesc = Solaris Porting Layer kernel headers.
conflicts = spl-archiso-linux-headers
+ conflicts = spl-archiso-linux-git-headers
conflicts = spl-linux-hardened-headers
conflicts = spl-linux-hardened-git-headers
conflicts = spl-linux-lts-headers
diff --git a/PKGBUILD b/PKGBUILD
index 1b18c0c19ca2..b78a34ffb15f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
pkgbase="spl-linux-git"
pkgname=("spl-linux-git" "spl-linux-git-headers")
-pkgver=2017.12.21.r1060.c9821f1.4.14.7.1
+pkgver=2017.12.21.r1060.c9821f1.4.14.8.1
pkgrel=1
-makedepends=("linux-headers=4.14.7-1" "git")
+makedepends=("linux-headers=4.14.8-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/spl.git#commit=c9821f1ccc647dfbd506f381b736c664d862d126")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git=2017.12.21.r1060.c9821f1" "kmod" "linux=4.14.7-1")
+depends=("spl-utils-common-git=2017.12.21.r1060.c9821f1" "kmod" "linux=4.14.8-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.14.7-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.14.7-1-ARCH/build \
+ --with-linux=/usr/lib/modules/4.14.8-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.14.8-1-ARCH/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-git() {
package_spl-linux-git-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.7-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.8-1-ARCH/Module.symvers
}
diff --git a/spl.install b/spl.install
index e91899fab1be..83e0e6ed9514 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.14.7-1-ARCH
+ depmod -a 4.14.8-1-ARCH
}