summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-13 16:26:22 -0700
committerJesus Alvarez2017-08-13 16:26:22 -0700
commitf6e6da875e9c6e5d531320d601d0b49b175234fb (patch)
tree078a28df89853e0c7253941b990b48af50cf8fc9
parentc3370e2a94a4731ed1cd9accf65425eff9f9186f (diff)
downloadaur-f6e6da875e9c6e5d531320d601d0b49b175234fb.tar.gz
Semi-automated update for 4.12.6.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f110647e338e..ae8f12428de2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Aug 10 04:31:41 UTC 2017
+# Sun Aug 13 20:49:26 UTC 2017
pkgbase = spl-linux-git
- pkgver = 0.7.0_r8_g9243b0f_4.12.4_1
+ pkgver = 0.7.0.r12.g9df9692.4.12.6.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-headers=4.12.4-1
+ makedepends = linux-headers=4.12.6-1
makedepends = git
- depends = spl-utils-common-git>=0.7.0_r8_g9243b0f
+ depends = spl-utils-common-git>=0.7.0.r12.g9df9692
depends = kmod
- depends = linux=4.12.4-1
+ depends = linux=4.12.6-1
source = git+https://github.com/zfsonlinux/spl.git
sha256sums = SKIP
@@ -30,4 +30,6 @@ pkgname = spl-linux-git-headers
conflicts = spl-linux-lts-headers
conflicts = spl-linux-lts-git-headers
conflicts = spl-linux-headers
+ conflicts = spl-linux-zen-headers
+ conflicts = spl-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index aaa0c7abc46e..caee93f91453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,22 +16,22 @@
#
pkgbase="spl-linux-git"
pkgname=("spl-linux-git" "spl-linux-git-headers")
-pkgver=0.7.0_r8_g9243b0f_4.12.4_1
+pkgver=0.7.0.r12.g9df9692.4.12.6.1
pkgrel=1
-makedepends=("linux-headers=4.12.4-1" "git")
+makedepends=("linux-headers=4.12.6-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/spl.git")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git>=0.7.0_r8_g9243b0f" "kmod" "linux=4.12.4-1")
+depends=("spl-utils-common-git>=0.7.0.r12.g9df9692" "kmod" "linux=4.12.6-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.12.4-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.12.4-1-ARCH/build \
+ --with-linux=/usr/lib/modules/4.12.6-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.12.6-1-ARCH/build \
--with-config=kernel
make
}
@@ -52,10 +52,10 @@ package_spl-linux-git() {
package_spl-linux-git-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.4-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.6-1-ARCH/Module.symvers
}
diff --git a/spl.install b/spl.install
index a589e22eb9a6..62ec494a7a3b 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.12.4-1-ARCH
+ depmod -a 4.12.6-1-ARCH
}