summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-18 22:14:13 -0700
committerJesus Alvarez2018-03-18 22:14:13 -0700
commit144999378964c0ba144891246264a2348d3db9d7 (patch)
treecb0a46bd492f578db7da9b709c801fc46142e09b
parent7329c5b9427e3d09bd095c77b7c9620a16c8ca21 (diff)
downloadaur-144999378964c0ba144891246264a2348d3db9d7.tar.gz
Semi-automated update for 4.15.10.a.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--spl.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e350e22666b..8b266fbbffda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = spl-linux-hardened
- pkgver = 0.7.6_4.15.9.a.1
+ pkgver = 0.7.6_4.15.10.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.15.9.a-1
+ makedepends = linux-hardened-headers=4.15.10.a-1
makedepends = git
depends = spl-utils-common=0.7.6
depends = kmod
- depends = linux-hardened=4.15.9.a-1
+ depends = linux-hardened=4.15.10.a-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz
sha256sums = 648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95
diff --git a/PKGBUILD b/PKGBUILD
index 8619627b8b7c..b5ff46ca0670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.6_4.15.9.a.1
+pkgver=0.7.6_4.15.10.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.9.a-1" "git")
+makedepends=("linux-hardened-headers=4.15.10.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz")
sha256sums=("648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95")
license=("GPL")
-depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.15.9.a-1")
+depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.15.10.a-1")
build() {
cd "${srcdir}/spl-0.7.6"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.9-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.9-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.15.10-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.10-1-hardened/build \
--with-config=kernel
make
}
@@ -58,5 +58,5 @@ package_spl-linux-hardened-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.9-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.10-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 534c5410fde5..285498e06859 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.15.9-1-hardened
+ depmod -a 4.15.10-1-hardened
}