summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-01 22:13:08 -0700
committerJesus Alvarez2017-08-01 22:13:08 -0700
commit2042f0e1c8d84629c0c4c35835857f9e1b6b333c (patch)
tree07974c265815551cfd6370d85ee10c388283204f
parent568eb1328f1587cf85c7950028d1404090bdaf82 (diff)
downloadaur-2042f0e1c8d84629c0c4c35835857f9e1b6b333c.tar.gz
Semi-automated update for 4.12.4.a_1-2
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD50
-rw-r--r--spl.install2
3 files changed, 53 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d7f417e0ac6..bd9a0be25104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,32 @@
# Generated by mksrcinfo v8
-# Tue Jul 11 14:11:32 UTC 2017
+# Wed Aug 2 02:45:48 UTC 2017
pkgbase = spl-linux-hardened
- pkgdesc = Solaris Porting Layer kernel modules.
- pkgver = 0.6.5.11_4.12.e.0_1
- pkgrel = 1
+ pkgver = 0.7.0_4.12.4.a_1
+ pkgrel = 2
url = http://zfsonlinux.org/
- install = spl.install
arch = x86_64
- groups = archzfs-linux-hardened
license = GPL
- makedepends = linux-hardened-headers=4.12.e-1
- depends = spl-utils-linux-hardened
+ makedepends = linux-hardened-headers=4.12.4.a-1
+ depends = spl-utils-common>=0.7.0
depends = kmod
- depends = linux-hardened=4.12.e-1
+ depends = linux-hardened=4.12.4.a-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/spl-0.7.0.tar.gz
+ sha256sums = 567f461435f99f862efb1b740ed0876b52a2a539aafad6e5372a84a06a5da4d3
+
+pkgname = spl-linux-hardened
+ pkgdesc = Solaris Porting Layer kernel modules.
+ install = spl.install
+ groups = archzfs-linux-hardened
provides = spl
- conflicts = spl-utils-linux
- conflicts = spl-utils-linux-git
- conflicts = spl-utils-linux-lts
- conflicts = spl-utils-linux-lts-git
conflicts = spl-linux-hardened-git
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.11/spl-0.6.5.11.tar.gz
- sha256sums = ebab87a064985f93122ad82721ca54569a5ef20dc3579f84d18075210cf316ac
-pkgname = spl-linux-hardened
+pkgname = spl-linux-hardened-headers
+ pkgdesc = Solaris Porting Layer kernel headers.
+ conflicts = spl-archiso-linux-headers
+ conflicts = spl-utils-common-git-headers
+ conflicts = spl-linux-hardened-git-headers
+ conflicts = spl-linux-lts-headers
+ conflicts = spl-linux-lts-git-headers
+ conflicts = spl-linux-headers
+ conflicts = spl-linux-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 838fb0ad6dc8..c2128f8d20e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# Maintainer: Jan Houben <jan@nexttrex.de>
# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
#
# This PKGBUILD was generated by the archzfs build scripts located at
#
-# http://github.com/minextu/archzfs/tree/linux-hardened
+# http://github.com/archzfs/archzfs
#
# ! WARNING !
#
@@ -16,36 +15,47 @@
# archzfs github page.
#
#
-pkgname="spl-linux-hardened"
-pkgver=0.6.5.11_4.12.e.0_1
-pkgrel=1
-pkgdesc="Solaris Porting Layer kernel modules."
-depends=("spl-utils-linux-hardened" "kmod" "linux-hardened=4.12.e-1")
-makedepends=("linux-hardened-headers=4.12.e-1")
+pkgbase="spl-linux-hardened"
+pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
+pkgver=0.7.0_4.12.4.a_1
+pkgrel=2
+makedepends=("linux-hardened-headers=4.12.4.a-1")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.11/spl-0.6.5.11.tar.gz")
-sha256sums=("ebab87a064985f93122ad82721ca54569a5ef20dc3579f84d18075210cf316ac")
-groups=("archzfs-linux-hardened")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/spl-0.7.0.tar.gz")
+sha256sums=("567f461435f99f862efb1b740ed0876b52a2a539aafad6e5372a84a06a5da4d3")
license=("GPL")
-install=spl.install
-provides=("spl")
-conflicts=('spl-utils-linux' 'spl-utils-linux-git' 'spl-utils-linux-lts' 'spl-utils-linux-lts-git' 'spl-linux-hardened-git')
+depends=("spl-utils-common>=0.7.0" "kmod" "linux-hardened=4.12.4.a-1")
build() {
- cd "${srcdir}/spl-0.6.5.11"
+ cd "${srcdir}/spl-0.7.0"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.12.0-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.0-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.12.4-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.4-1-hardened/build \
--with-config=kernel
make
}
-package() {
- cd "${srcdir}/spl-0.6.5.11"
+package_spl-linux-hardened() {
+ pkgdesc="Solaris Porting Layer kernel modules."
+ install=spl.install
+ provides=("spl")
+ groups=("archzfs-linux-hardened")
+ conflicts=('spl-linux-hardened-git')
+ cd "${srcdir}/spl-0.7.0"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/lib" "${pkgdir}/usr/"
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_spl-linux-hardened-headers() {
+ pkgdesc="Solaris Porting Layer kernel headers."
+ conflicts=('spl-archiso-linux-headers' 'spl-utils-common-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' )
+ cd "${srcdir}/spl-0.7.0"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.0-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.4-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 4b66a148612e..f87cc8658a80 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.12.0-1-hardened
+ depmod -a 4.12.4-1-hardened
}