summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-23 21:06:43 -0700
committerJesus Alvarez2018-03-23 21:06:43 -0700
commit242f5f40852ea25c0ca3cdd65aa88ee67650951b (patch)
tree36beced7ce90e88b5f7416f3850dd3c48f4f0ca0
parente1b01b26cbb82771bdd1fd0ab5f20200bf27daea (diff)
downloadaur-242f5f40852ea25c0ca3cdd65aa88ee67650951b.tar.gz
Semi-automated update for 4.15.12.a.1-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--spl.install2
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9f315459eec..09052caf6a5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = spl-linux-hardened
- pkgver = 0.7.7_4.15.11.a.1
+ pkgver = 0.7.7_4.15.12.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.15.11.a-1
+ makedepends = linux-hardened-headers=4.15.12.a-1
+ makedepends = git
depends = spl-utils-common=0.7.7
depends = kmod
- depends = linux-hardened=4.15.11.a-1
+ depends = linux-hardened=4.15.12.a-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.7/spl-0.7.7.tar.gz
sha256sums = 9e98af3daaf1a6605b34f8b709a60cfc52dbf2bedcfc01d919d1f77c695247de
diff --git a/PKGBUILD b/PKGBUILD
index d48e31ec5481..bbe0f8d5cda6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.7_4.15.11.a.1
+pkgver=0.7.7_4.15.12.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.11.a-1")
+makedepends=("linux-hardened-headers=4.15.12.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.7/spl-0.7.7.tar.gz")
sha256sums=("9e98af3daaf1a6605b34f8b709a60cfc52dbf2bedcfc01d919d1f77c695247de")
license=("GPL")
-depends=("spl-utils-common=0.7.7" "kmod" "linux-hardened=4.15.11.a-1")
+depends=("spl-utils-common=0.7.7" "kmod" "linux-hardened=4.15.12.a-1")
build() {
cd "${srcdir}/spl-0.7.7"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.11-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.11-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.15.12-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.12-1-hardened/build \
--with-config=kernel
make
}
@@ -58,5 +58,5 @@ package_spl-linux-hardened-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.11-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.12-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 241b2da2c402..e053fad25e04 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.15.11-1-hardened
+ depmod -a 4.15.12-1-hardened
}