summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-05-11 15:48:35 -0700
committerJesus Alvarez2018-05-11 15:48:35 -0700
commit617ea10fce44b332eb36447bf924ae38a836938f (patch)
tree3b736082ebc3e783ca5fe9ed8df236a0c83423a6
parent64caaa990a6116193f570735bef780cc99045b1f (diff)
downloadaur-617ea10fce44b332eb36447bf924ae38a836938f.tar.gz
Semi-automated update for 4.16.8.a.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--spl.install2
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 482525130974..783546d2ab62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = spl-linux-hardened
- pkgver = 0.7.8_4.16.7.a.1
- pkgrel = 2
+ pkgver = 0.7.9_4.16.8.a.1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.16.7.a-1
+ makedepends = linux-hardened-headers=4.16.8.a-1
makedepends = git
- depends = spl-utils-common=0.7.8
+ depends = spl-utils-common=0.7.9
depends = kmod
- depends = linux-hardened=4.16.7.a-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/spl-0.7.8.tar.gz
- sha256sums = f6c9fe37d149da7fec34ee3bf32302a16b4cfcd84b8c6aa3d764ceb816587636
+ depends = linux-hardened=4.16.8.a-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/spl-0.7.9.tar.gz
+ sha256sums = 49832e446a5abce0b55ba245c9b5f94959604d44378320fdffae0233bf1e8c00
pkgname = spl-linux-hardened
pkgdesc = Solaris Porting Layer kernel modules.
diff --git a/PKGBUILD b/PKGBUILD
index c23d53918091..e78ac8a6c9c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.8_4.16.7.a.1
-pkgrel=2
-makedepends=("linux-hardened-headers=4.16.7.a-1" "git")
+pkgver=0.7.9_4.16.8.a.1
+pkgrel=1
+makedepends=("linux-hardened-headers=4.16.8.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/spl-0.7.8.tar.gz")
-sha256sums=("f6c9fe37d149da7fec34ee3bf32302a16b4cfcd84b8c6aa3d764ceb816587636")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/spl-0.7.9.tar.gz")
+sha256sums=("49832e446a5abce0b55ba245c9b5f94959604d44378320fdffae0233bf1e8c00")
license=("GPL")
-depends=("spl-utils-common=0.7.8" "kmod" "linux-hardened=4.16.7.a-1")
+depends=("spl-utils-common=0.7.9" "kmod" "linux-hardened=4.16.8.a-1")
build() {
- cd "${srcdir}/spl-0.7.8"
+ cd "${srcdir}/spl-0.7.9"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.16.7-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.16.7-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.16.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.16.8-1-hardened/build \
--with-config=kernel
make
}
@@ -44,7 +44,7 @@ package_spl-linux-hardened() {
provides=("spl")
groups=("archzfs-linux-hardened")
conflicts=('spl-linux-hardened-git')
- cd "${srcdir}/spl-0.7.8"
+ cd "${srcdir}/spl-0.7.9"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# Remove src dir
@@ -54,9 +54,9 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
- cd "${srcdir}/spl-0.7.8"
+ cd "${srcdir}/spl-0.7.9"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.7-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.8-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 3282507152fe..9d3980d6acb4 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.16.7-1-hardened
+ depmod -a 4.16.8-1-hardened
}