summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-02-06 11:01:56 -0800
committerJesus Alvarez2018-02-06 11:01:56 -0800
commit65eb78cbeea08e47be1fa43cfae201b185d27d04 (patch)
treef55f37f18721e6217f05ff40b74f4a70b4ea7743
parent1e73f5b2d318f61442a7de3707ae0156d33b0ab6 (diff)
downloadaur-65eb78cbeea08e47be1fa43cfae201b185d27d04.tar.gz
Semi-automated update for 4.14.17.a.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--spl.install2
3 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d73d0ddaedb2..d4f5bf282993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Jan 18 23:54:22 UTC 2018
pkgbase = spl-linux-hardened
- pkgver = 0.7.5_4.14.14.a.1
+ pkgver = 0.7.6_4.14.17.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.14.14.a-1
+ makedepends = linux-hardened-headers=4.14.17.a-1
makedepends = git
- depends = spl-utils-common=0.7.5
+ depends = spl-utils-common=0.7.6
depends = kmod
- depends = linux-hardened=4.14.14.a-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/spl-0.7.5.tar.gz
- sha256sums = SKIP
+ depends = linux-hardened=4.14.17.a-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz
+ sha256sums = 648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95
pkgname = spl-linux-hardened
pkgdesc = Solaris Porting Layer kernel modules.
diff --git a/PKGBUILD b/PKGBUILD
index 8828325263d8..5f2bc270edd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.5_4.14.14.a.1
+pkgver=0.7.6_4.14.17.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.14.a-1" "git")
+makedepends=("linux-hardened-headers=4.14.17.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/spl-0.7.5.tar.gz")
-sha256sums=("SKIP")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz")
+sha256sums=("648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95")
license=("GPL")
-depends=("spl-utils-common=0.7.5" "kmod" "linux-hardened=4.14.14.a-1")
+depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.14.17.a-1")
build() {
- cd "${srcdir}/spl-0.7.5"
+ cd "${srcdir}/spl-0.7.6"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.14.14-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.14-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.14.17-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.17-1-hardened/build \
--with-config=kernel
make
}
@@ -44,7 +44,7 @@ package_spl-linux-hardened() {
provides=("spl")
groups=("archzfs-linux-hardened")
conflicts=('spl-linux-hardened-git')
- cd "${srcdir}/spl-0.7.5"
+ cd "${srcdir}/spl-0.7.6"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# Remove src dir
@@ -54,9 +54,9 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
- cd "${srcdir}/spl-0.7.5"
+ cd "${srcdir}/spl-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.14-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.17-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 258563bddcc5..ac5cc8db4e86 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.14.14-1-hardened
+ depmod -a 4.14.17-1-hardened
}