summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-21 18:55:45 -0800
committerJesus Alvarez2017-12-21 18:55:45 -0800
commit6bba9ccdff214400103cc8448e6a343e1b730883 (patch)
treeb853e2d3a9563574b326e8d2af4d87a04e1bc8ed
parent2045b6915b6356ea33877ac5a8d8678222a89587 (diff)
downloadaur-6bba9ccdff214400103cc8448e6a343e1b730883.tar.gz
Semi-automated update for 4.14.8.b.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--spl.install2
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66a4b9ec7f38..2f1596d801b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Mon Dec 18 22:18:03 UTC 2017
+# Fri Dec 22 00:59:02 UTC 2017
pkgbase = spl-linux-hardened
- pkgver = 0.7.4_4.14.7.a.1
+ pkgver = 0.7.5_4.14.8.b.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.14.7.a-1
+ makedepends = linux-hardened-headers=4.14.8.b-1
makedepends = git
- depends = spl-utils-common=0.7.4
+ depends = spl-utils-common=0.7.5
depends = kmod
- depends = linux-hardened=4.14.7.a-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/spl-0.7.4.tar.gz
+ depends = linux-hardened=4.14.8.b-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/spl-0.7.5.tar.gz
sha256sums = SKIP
pkgname = spl-linux-hardened
diff --git a/PKGBUILD b/PKGBUILD
index 46fe8e6361b2..ad71dc0abf05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.4_4.14.7.a.1
+pkgver=0.7.5_4.14.8.b.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.7.a-1" "git")
+makedepends=("linux-hardened-headers=4.14.8.b-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/spl-0.7.4.tar.gz")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/spl-0.7.5.tar.gz")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common=0.7.4" "kmod" "linux-hardened=4.14.7.a-1")
+depends=("spl-utils-common=0.7.5" "kmod" "linux-hardened=4.14.8.b-1")
build() {
- cd "${srcdir}/spl-0.7.4"
+ cd "${srcdir}/spl-0.7.5"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.14.7-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.7-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.14.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.8-1-hardened/build \
--with-config=kernel
make
}
@@ -44,7 +44,7 @@ package_spl-linux-hardened() {
provides=("spl")
groups=("archzfs-linux-hardened")
conflicts=('spl-linux-hardened-git')
- cd "${srcdir}/spl-0.7.4"
+ cd "${srcdir}/spl-0.7.5"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# Remove src dir
@@ -54,9 +54,9 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
- cd "${srcdir}/spl-0.7.4"
+ cd "${srcdir}/spl-0.7.5"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.7-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.8-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 2981133ae065..59f0f52d7645 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.14.7-1-hardened
+ depmod -a 4.14.8-1-hardened
}