summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-26 09:52:32 -0800
committerJesus Alvarez2017-12-26 09:52:32 -0800
commitbb746388bb9dac805a07d1f4f806725171e16f06 (patch)
treeae5ec8b804c96ba6c769f1699731cd097a583477
parent6bba9ccdff214400103cc8448e6a343e1b730883 (diff)
downloadaur-bb746388bb9dac805a07d1f4f806725171e16f06.tar.gz
Semi-automated update for 4.14.9.a.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--spl.install2
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f1596d801b6..4c9d994432fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Dec 22 00:59:02 UTC 2017
+# Tue Dec 26 03:43:14 UTC 2017
pkgbase = spl-linux-hardened
- pkgver = 0.7.5_4.14.8.b.1
+ pkgver = 0.7.5_4.14.9.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.14.8.b-1
- makedepends = git
+ makedepends = linux-hardened-headers=4.14.9.a-1
depends = spl-utils-common=0.7.5
depends = kmod
- depends = linux-hardened=4.14.8.b-1
+ depends = linux-hardened=4.14.9.a-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/spl-0.7.5.tar.gz
- sha256sums = SKIP
+ sha256sums = c4845d9a6123397c53ee003ed1712f2996a50ac2a9a30d1490280771484d08a6
pkgname = spl-linux-hardened
pkgdesc = Solaris Porting Layer kernel modules.
@@ -24,6 +23,7 @@ pkgname = spl-linux-hardened
pkgname = spl-linux-hardened-headers
pkgdesc = Solaris Porting Layer kernel headers.
conflicts = spl-archiso-linux-headers
+ conflicts = spl-archiso-linux-git-headers
conflicts = spl-linux-hardened-git-headers
conflicts = spl-linux-lts-headers
conflicts = spl-linux-lts-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index ad71dc0abf05..286aa5616d8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.5_4.14.8.b.1
+pkgver=0.7.5_4.14.9.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.8.b-1" "git")
+makedepends=("linux-hardened-headers=4.14.9.a-1")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/spl-0.7.5.tar.gz")
-sha256sums=("SKIP")
+sha256sums=("c4845d9a6123397c53ee003ed1712f2996a50ac2a9a30d1490280771484d08a6")
license=("GPL")
-depends=("spl-utils-common=0.7.5" "kmod" "linux-hardened=4.14.8.b-1")
+depends=("spl-utils-common=0.7.5" "kmod" "linux-hardened=4.14.9.a-1")
build() {
cd "${srcdir}/spl-0.7.5"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.14.8-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.8-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.14.9-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.9-1-hardened/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl-0.7.5"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.8-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.9-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 59f0f52d7645..52c66e1990a5 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.14.8-1-hardened
+ depmod -a 4.14.9-1-hardened
}