summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-12 17:08:03 -0700
committerJesus Alvarez2018-03-12 17:08:03 -0700
commitc10dccec87c1ce0391cb78c5fd4109d1e7bcd2bd (patch)
tree976a4328b9db91b1290440134392c527e49471bc
parent748db91e9b611394fe35dc232f5608eea680fa24 (diff)
downloadaur-c10dccec87c1ce0391cb78c5fd4109d1e7bcd2bd.tar.gz
Semi-automated update for 4.15.8.a.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--spl.install2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b5d49fa4b15..6adfde698566 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = spl-linux-hardened
- pkgver = 0.7.6_4.15.7.a.1
- pkgrel = 2
+ pkgver = 0.7.6_4.15.8.a.1
+ pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.15.7.a-1
+ makedepends = linux-hardened-headers=4.15.8.a-1
makedepends = git
depends = spl-utils-common=0.7.6
depends = kmod
- depends = linux-hardened=4.15.7.a-1
+ depends = linux-hardened=4.15.8.a-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz
sha256sums = 648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95
@@ -30,6 +30,8 @@ pkgname = spl-linux-hardened-headers
conflicts = spl-linux-git-headers
conflicts = spl-linux-threadripper-headers
conflicts = spl-linux-threadripper-git-headers
+ conflicts = spl-linux-threadripper-vfio-headers
+ conflicts = spl-linux-threadripper-vfio-git-headers
conflicts = spl-linux-vfio-headers
conflicts = spl-linux-vfio-git-headers
conflicts = spl-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index b4aa8a69d787..7029d0323821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.6_4.15.7.a.1
-pkgrel=2
-makedepends=("linux-hardened-headers=4.15.7.a-1" "git")
+pkgver=0.7.6_4.15.8.a.1
+pkgrel=1
+makedepends=("linux-hardened-headers=4.15.8.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz")
sha256sums=("648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95")
license=("GPL")
-depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.15.7.a-1")
+depends=("spl-utils-common=0.7.6" "kmod" "linux-hardened=4.15.8.a-1")
build() {
cd "${srcdir}/spl-0.7.6"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.7-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.7-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.15.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.8-1-hardened/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-hardened() {
package_spl-linux-hardened-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-threadripper-headers' 'spl-linux-threadripper-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-threadripper-headers' 'spl-linux-threadripper-git-headers' 'spl-linux-threadripper-vfio-headers' 'spl-linux-threadripper-vfio-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.7-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.8-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 1686e4972ed3..65bc3a76943d 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.15.7-1-hardened
+ depmod -a 4.15.8-1-hardened
}