summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-06-03 02:36:53 -0700
committerJesus Alvarez2018-06-03 02:36:53 -0700
commitdb229c4b0afef3ea6eef3a57cf765b7ad34e06cc (patch)
treefb211eb5538187a0aa410148957a33ff4ce432ac
parent1527f740ecd548fcd15788845561e120ec2b8b24 (diff)
downloadaur-db229c4b0afef3ea6eef3a57cf765b7ad34e06cc.tar.gz
Semi-automated update for 4.16.13.a.1-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--spl.install2
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 720844966c8c..0b61279f4fa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = spl-linux-hardened
- pkgver = 0.7.9_4.16.11.a.1
+ pkgver = 0.7.9_4.16.13.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.16.11.a-1
- makedepends = git
+ makedepends = linux-hardened-headers=4.16.13.a-1
depends = spl-utils-common=0.7.9
depends = kmod
- depends = linux-hardened=4.16.11.a-1
+ depends = linux-hardened=4.16.13.a-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/spl-0.7.9.tar.gz
sha256sums = 49832e446a5abce0b55ba245c9b5f94959604d44378320fdffae0233bf1e8c00
diff --git a/PKGBUILD b/PKGBUILD
index ea695dc4cf79..625524688b60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened"
pkgname=("spl-linux-hardened" "spl-linux-hardened-headers")
-pkgver=0.7.9_4.16.11.a.1
+pkgver=0.7.9_4.16.13.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.16.11.a-1" "git")
+makedepends=("linux-hardened-headers=4.16.13.a-1")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/spl-0.7.9.tar.gz")
sha256sums=("49832e446a5abce0b55ba245c9b5f94959604d44378320fdffae0233bf1e8c00")
license=("GPL")
-depends=("spl-utils-common=0.7.9" "kmod" "linux-hardened=4.16.11.a-1")
+depends=("spl-utils-common=0.7.9" "kmod" "linux-hardened=4.16.13.a-1")
build() {
cd "${srcdir}/spl-0.7.9"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.16.11-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.16.11-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.16.13-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.16.13-1-hardened/build \
--with-config=kernel
make
}
@@ -58,5 +58,5 @@ package_spl-linux-hardened-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.11-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.13-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 0463132cc811..8878354ac94d 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.16.11-1-hardened
+ depmod -a 4.16.13-1-hardened
}