summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-03 18:02:45 -0800
committerJesus Alvarez2018-03-03 18:02:45 -0800
commit6f856ede5b2017c2c9a8626d80b4d5b1eb5c2513 (patch)
treef5e745d1fcc28829c973d41272669f36b8275165
parent1973c0b2681313e4897a1b44b55a3b640d91bd40 (diff)
downloadaur-6f856ede5b2017c2c9a8626d80b4d5b1eb5c2513.tar.gz
Semi-automated update for 4.15.7.a.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--spl.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53ba4cdd0421..a93bf76f9e49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = spl-linux-hardened-git
- pkgver = 2018.02.24.r1068.3673d03.4.15.6.a.1
+ pkgver = 2018.02.24.r1068.3673d03.4.15.7.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.15.6.a-1
+ makedepends = linux-hardened-headers=4.15.7.a-1
makedepends = git
depends = spl-utils-common-git=2018.02.24.r1068.3673d03
depends = kmod
- depends = linux-hardened=4.15.6.a-1
+ depends = linux-hardened=4.15.7.a-1
source = git+https://github.com/zfsonlinux/spl.git#commit=3673d032850c3b54b8b2cc74cf1782a75cc9b2a9
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 303d989fad4f..95c0fd6b6028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened-git"
pkgname=("spl-linux-hardened-git" "spl-linux-hardened-git-headers")
-pkgver=2018.02.24.r1068.3673d03.4.15.6.a.1
+pkgver=2018.02.24.r1068.3673d03.4.15.7.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.6.a-1" "git")
+makedepends=("linux-hardened-headers=4.15.7.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/spl.git#commit=3673d032850c3b54b8b2cc74cf1782a75cc9b2a9")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git=2018.02.24.r1068.3673d03" "kmod" "linux-hardened=4.15.6.a-1")
+depends=("spl-utils-common-git=2018.02.24.r1068.3673d03" "kmod" "linux-hardened=4.15.7.a-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.6-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.6-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.15.7-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.7-1-hardened/build \
--with-config=kernel
make
}
@@ -58,5 +58,5 @@ package_spl-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.6-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.7-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index 0285bf484fc0..1686e4972ed3 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.15.6-1-hardened
+ depmod -a 4.15.7-1-hardened
}