summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-04-05 22:48:54 -0700
committerJesus Alvarez2018-04-05 22:48:54 -0700
commitfbf1dd72587ba18472ebc3bbe5c4deed55661d27 (patch)
treedccb89384b4e8f47bac9f2359af7c712a2911e41
parent4688c950bfd7071b2bc30a9dbf72bed6dc620454 (diff)
downloadaur-fbf1dd72587ba18472ebc3bbe5c4deed55661d27.tar.gz
Semi-automated update for 4.15.15.a.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b90fee1d551c..b54fd7ed09d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = spl-linux-hardened-git
- pkgver = 2018.03.09.r1069.43983eb.4.15.12.a.1
+ pkgver = 2018.04.04.r1070.581bc01.4.15.15.a.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-hardened-headers=4.15.12.a-1
+ makedepends = linux-hardened-headers=4.15.15.a-1
makedepends = git
- depends = spl-utils-common-git=2018.03.09.r1069.43983eb
+ depends = spl-utils-common-git=2018.04.04.r1070.581bc01
depends = kmod
- depends = linux-hardened=4.15.12.a-1
- source = git+https://github.com/zfsonlinux/spl.git#commit=43983eb2024ec6b3280e6e06a6fb621ee3bb2a41
+ depends = linux-hardened=4.15.15.a-1
+ source = git+https://github.com/zfsonlinux/spl.git#commit=581bc01a0765eed9ea7dc17132b3943a5efc966d
sha256sums = SKIP
pkgname = spl-linux-hardened-git
diff --git a/PKGBUILD b/PKGBUILD
index e78f75a6d47f..6a43457c493d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-hardened-git"
pkgname=("spl-linux-hardened-git" "spl-linux-hardened-git-headers")
-pkgver=2018.03.09.r1069.43983eb.4.15.12.a.1
+pkgver=2018.04.04.r1070.581bc01.4.15.15.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.15.12.a-1" "git")
+makedepends=("linux-hardened-headers=4.15.15.a-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/spl.git#commit=43983eb2024ec6b3280e6e06a6fb621ee3bb2a41")
+source=("git+https://github.com/zfsonlinux/spl.git#commit=581bc01a0765eed9ea7dc17132b3943a5efc966d")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git=2018.03.09.r1069.43983eb" "kmod" "linux-hardened=4.15.12.a-1")
+depends=("spl-utils-common-git=2018.04.04.r1070.581bc01" "kmod" "linux-hardened=4.15.15.a-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.15.12-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.15.12-1-hardened/build \
+ --with-linux=/usr/lib/modules/4.15.15-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.15.15-1-hardened/build \
--with-config=kernel
make
}
@@ -58,5 +58,5 @@ package_spl-linux-hardened-git-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.12-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.15-1-hardened/Module.symvers
}
diff --git a/spl.install b/spl.install
index e053fad25e04..f4ac597e3a46 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.15.12-1-hardened
+ depmod -a 4.15.15-1-hardened
}