summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-16 20:52:59 -0700
committerJesus Alvarez2018-03-16 20:52:59 -0700
commit9d1faaafaf3ba0aae968081511e631595e5f8fcb (patch)
treef16b1f3fc3823ea55d3fa847d6dbdb35175e5897
parentd26eaf33522df1904974b63da5ccf23d6e9a0e9b (diff)
downloadaur-9d1faaafaf3ba0aae968081511e631595e5f8fcb.tar.gz
Semi-automated update for 4.14.27.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d25d6677cb27..09d5d0190c99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = spl-linux-lts-git
- pkgver = 2018.03.09.r1069.43983eb.4.14.25.1
+ pkgver = 2018.03.09.r1069.43983eb.4.14.27.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-lts-headers=4.14.25-1
+ makedepends = linux-lts-headers=4.14.27-1
makedepends = libelf
makedepends = git
depends = spl-utils-common-git=2018.03.09.r1069.43983eb
depends = kmod
- depends = linux-lts=4.14.25-1
+ depends = linux-lts=4.14.27-1
source = git+https://github.com/zfsonlinux/spl.git#commit=43983eb2024ec6b3280e6e06a6fb621ee3bb2a41
sha256sums = SKIP
@@ -29,10 +29,6 @@ pkgname = spl-linux-lts-git-headers
conflicts = spl-linux-lts-headers
conflicts = spl-linux-headers
conflicts = spl-linux-git-headers
- conflicts = spl-linux-threadripper-headers
- conflicts = spl-linux-threadripper-git-headers
- conflicts = spl-linux-threadripper-vfio-headers
- conflicts = spl-linux-threadripper-vfio-git-headers
conflicts = spl-linux-vfio-headers
conflicts = spl-linux-vfio-git-headers
conflicts = spl-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index fad50eba4230..8fe9e2a66779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-lts-git"
pkgname=("spl-linux-lts-git" "spl-linux-lts-git-headers")
-pkgver=2018.03.09.r1069.43983eb.4.14.25.1
+pkgver=2018.03.09.r1069.43983eb.4.14.27.1
pkgrel=1
-makedepends=("linux-lts-headers=4.14.25-1" "libelf" "git")
+makedepends=("linux-lts-headers=4.14.27-1" "libelf" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/spl.git#commit=43983eb2024ec6b3280e6e06a6fb621ee3bb2a41")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git=2018.03.09.r1069.43983eb" "kmod" "linux-lts=4.14.25-1")
+depends=("spl-utils-common-git=2018.03.09.r1069.43983eb" "kmod" "linux-lts=4.14.27-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.14.25-1-lts/build \
- --with-linux-obj=/usr/lib/modules/4.14.25-1-lts/build \
+ --with-linux=/usr/lib/modules/4.14.27-1-lts/build \
+ --with-linux-obj=/usr/lib/modules/4.14.27-1-lts/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-lts-git() {
package_spl-linux-lts-git-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-threadripper-headers' 'spl-linux-threadripper-git-headers' 'spl-linux-threadripper-vfio-headers' 'spl-linux-threadripper-vfio-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.25-1-lts/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.14.27-1-lts/Module.symvers
}
diff --git a/spl.install b/spl.install
index c75e1f97f8d6..cb45e78138f4 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.14.25-1-lts
+ depmod -a 4.14.27-1-lts
}