summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-26 09:53:56 -0800
committerJesus Alvarez2017-12-26 09:53:56 -0800
commitc3019b9f62ea76adf2c85dc052621fe34a96129c (patch)
treedeabf6a68e17316a2636de7b88b2ba5997a74718
parent8c23c98a52b540ad29f3bfd83727c7ecc0330c9f (diff)
downloadaur-c3019b9f62ea76adf2c85dc052621fe34a96129c.tar.gz
Semi-automated update for 4.9.71.1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcb754adcddc..83985b8ce371 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Dec 22 01:11:08 UTC 2017
+# Sun Dec 24 18:51:11 UTC 2017
pkgbase = spl-linux-lts-git
- pkgver = 2017.12.21.r1060.c9821f1.4.9.70.1
+ pkgver = 2017.12.21.r1060.c9821f1.4.9.71.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-lts-headers=4.9.70-1
+ makedepends = linux-lts-headers=4.9.71-1
makedepends = libelf
makedepends = git
depends = spl-utils-common-git=2017.12.21.r1060.c9821f1
depends = kmod
- depends = linux-lts=4.9.70-1
+ depends = linux-lts=4.9.71-1
source = git+https://github.com/zfsonlinux/spl.git#commit=c9821f1ccc647dfbd506f381b736c664d862d126
sha256sums = SKIP
@@ -25,6 +25,7 @@ pkgname = spl-linux-lts-git
pkgname = spl-linux-lts-git-headers
pkgdesc = Solaris Porting Layer kernel headers.
conflicts = spl-archiso-linux-headers
+ conflicts = spl-archiso-linux-git-headers
conflicts = spl-linux-hardened-headers
conflicts = spl-linux-hardened-git-headers
conflicts = spl-linux-lts-headers
diff --git a/PKGBUILD b/PKGBUILD
index ebaa0a1f5aec..9df43c075bfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="spl-linux-lts-git"
pkgname=("spl-linux-lts-git" "spl-linux-lts-git-headers")
-pkgver=2017.12.21.r1060.c9821f1.4.9.70.1
+pkgver=2017.12.21.r1060.c9821f1.4.9.71.1
pkgrel=1
-makedepends=("linux-lts-headers=4.9.70-1" "libelf" "git")
+makedepends=("linux-lts-headers=4.9.71-1" "libelf" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/spl.git#commit=c9821f1ccc647dfbd506f381b736c664d862d126")
sha256sums=("SKIP")
license=("GPL")
-depends=("spl-utils-common-git=2017.12.21.r1060.c9821f1" "kmod" "linux-lts=4.9.70-1")
+depends=("spl-utils-common-git=2017.12.21.r1060.c9821f1" "kmod" "linux-lts=4.9.71-1")
build() {
cd "${srcdir}/spl"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.9.70-1-lts/build \
- --with-linux-obj=/usr/lib/modules/4.9.70-1-lts/build \
+ --with-linux=/usr/lib/modules/4.9.71-1-lts/build \
+ --with-linux-obj=/usr/lib/modules/4.9.71-1-lts/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-lts-git() {
package_spl-linux-lts-git-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.9.70-1-lts/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.9.71-1-lts/Module.symvers
}
diff --git a/spl.install b/spl.install
index d11f3f5d216e..9059767d1e05 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.9.70-1-lts
+ depmod -a 4.9.71-1-lts
}