summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-06 21:44:17 -0800
committerJesus Alvarez2018-03-06 21:44:17 -0800
commit8c41f25f7d21f648d28bc1b56cd847a78fc77855 (patch)
tree9fb5c1944657c49db269017cc6f9167cf89544b4
parentc9cb27a18811f5b0d7ba679ce93472be2a29edf6 (diff)
downloadaur-8c41f25f7d21f648d28bc1b56cd847a78fc77855.tar.gz
Semi-automated update for 4.15.2.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--spl.install2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c24e66840dc..edf010e19a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = spl-linux-vfio
- pkgver = 0.7.6.4.13.12.2
+ pkgver = 0.7.6.4.15.2.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-vfio-headers=4.13.12-2
- makedepends = git
+ makedepends = linux-vfio-headers=4.15.2-1
depends = spl-utils-common=0.7.6
depends = kmod
- depends = linux-vfio=4.13.12-2
+ depends = linux-vfio=4.15.2-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz
sha256sums = 648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95
@@ -18,7 +17,6 @@ pkgname = spl-linux-vfio
groups = archzfs-linux-vfio
provides = spl
conflicts = spl-linux-vfio-git
- replaces = spl-git
pkgname = spl-linux-vfio-headers
pkgdesc = Solaris Porting Layer kernel headers.
@@ -30,6 +28,8 @@ pkgname = spl-linux-vfio-headers
conflicts = spl-linux-lts-git-headers
conflicts = spl-linux-headers
conflicts = spl-linux-git-headers
+ conflicts = spl-linux-threadripper-headers
+ conflicts = spl-linux-threadripper-git-headers
conflicts = spl-linux-vfio-git-headers
conflicts = spl-linux-zen-headers
conflicts = spl-linux-zen-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 329eaf5ca129..96fd6686a40a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
pkgbase="spl-linux-vfio"
pkgname=("spl-linux-vfio" "spl-linux-vfio-headers")
-pkgver=0.7.6.4.13.12.2
+pkgver=0.7.6.4.15.2.1
pkgrel=1
-makedepends=("linux-vfio-headers=4.13.12-2" "git")
+makedepends=("linux-vfio-headers=4.15.2-1" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/spl-0.7.6.tar.gz")
sha256sums=("648148762969d1ee94290c494c4f022aeacabe0e84cddf65906af608be666f95")
license=("GPL")
-depends=("spl-utils-common=0.7.6" "kmod" "linux-vfio=4.13.12-2")
+depends=("spl-utils-common=0.7.6" "kmod" "linux-vfio=4.15.2-1")
build() {
cd "${srcdir}/spl-0.7.6"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.13.12-2-vfio/build \
- --with-linux-obj=/usr/lib/modules/4.13.12-2-vfio/build \
+ --with-linux=/usr/lib/modules/4.15.2-1-vfio/build \
+ --with-linux-obj=/usr/lib/modules/4.15.2-1-vfio/build \
--with-config=kernel
make
}
@@ -53,10 +53,10 @@ package_spl-linux-vfio() {
package_spl-linux-vfio-headers() {
pkgdesc="Solaris Porting Layer kernel headers."
- conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ conflicts=('spl-archiso-linux-headers' 'spl-archiso-linux-git-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-threadripper-headers' 'spl-linux-threadripper-git-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
cd "${srcdir}/spl-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.13.12-2-vfio/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.15.2-1-vfio/Module.symvers
}
diff --git a/spl.install b/spl.install
index d5318b9c99e3..d4774200f648 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.13.12-2-vfio
+ depmod -a 4.15.2-1-vfio
}