summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2018-06-27 16:44:09 -0700
committerJesus Alvarez2018-06-27 16:44:09 -0700
commitcc57be4593144203ac4eeec7c01eb2b8031776e1 (patch)
treecb758c54d4a5dcdb158bdc9fdcd4f05e053993db
parent148b01aa1130e9c459d6c93b200bd7a41487bcfe (diff)
downloadaur-cc57be4593144203ac4eeec7c01eb2b8031776e1.tar.gz
Semi-automated update for 4.17.2.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--spl.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e9706ba719a..9cd99ad704e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = spl-linux-vfio
- pkgver = 0.7.9.4.16.13.1
+ pkgver = 0.7.9.4.17.2.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = GPL
- makedepends = linux-vfio-headers=4.16.13-1
+ makedepends = linux-vfio-headers=4.17.2-1
depends = spl-utils-common=0.7.9
depends = kmod
- depends = linux-vfio=4.16.13-1
+ depends = linux-vfio=4.17.2-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/spl-0.7.9.tar.gz
sha256sums = 49832e446a5abce0b55ba245c9b5f94959604d44378320fdffae0233bf1e8c00
diff --git a/PKGBUILD b/PKGBUILD
index 9326cc80b661..503d0d1d77ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
pkgbase="spl-linux-vfio"
pkgname=("spl-linux-vfio" "spl-linux-vfio-headers")
-pkgver=0.7.9.4.16.13.1
+pkgver=0.7.9.4.17.2.1
pkgrel=1
-makedepends=("linux-vfio-headers=4.16.13-1")
+makedepends=("linux-vfio-headers=4.17.2-1")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/spl-0.7.9.tar.gz")
sha256sums=("49832e446a5abce0b55ba245c9b5f94959604d44378320fdffae0233bf1e8c00")
license=("GPL")
-depends=("spl-utils-common=0.7.9" "kmod" "linux-vfio=4.16.13-1")
+depends=("spl-utils-common=0.7.9" "kmod" "linux-vfio=4.17.2-1")
build() {
cd "${srcdir}/spl-0.7.9"
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
- --with-linux=/usr/lib/modules/4.16.13-1-vfio/build \
- --with-linux-obj=/usr/lib/modules/4.16.13-1-vfio/build \
+ --with-linux=/usr/lib/modules/4.17.2-1-vfio/build \
+ --with-linux-obj=/usr/lib/modules/4.17.2-1-vfio/build \
--with-config=kernel
make
}
@@ -57,5 +57,5 @@ package_spl-linux-vfio-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.16.13-1-vfio/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.17.2-1-vfio/Module.symvers
}
diff --git a/spl.install b/spl.install
index 0e443a822e6d..8080c6310015 100644
--- a/spl.install
+++ b/spl.install
@@ -12,5 +12,5 @@ post_upgrade() {
run_depmod() {
echo ">>> Updating SPL module dependencies"
- depmod -a 4.16.13-1-vfio
+ depmod -a 4.17.2-1-vfio
}