summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Houben2017-07-15 13:25:35 +0200
committerJan Houben2017-07-15 13:25:35 +0200
commit4b47296c79cb243a5cb397d368a01285d3c8cfb2 (patch)
treead2dbed2530b8403200c45482c25f213b7c237ad
downloadaur-4b47296c79cb243a5cb397d368a01285d3c8cfb2.tar.gz
first commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f4428757875
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Jul 15 11:24:35 UTC 2017
+pkgbase = spl-utils-common-git
+ pkgdesc = Solaris Porting Layer kernel module support files.
+ pkgver = 0.7.0_rc5_r0_gae42190
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ arch = x86_64
+ groups = archzfs-linux-git
+ license = GPL
+ makedepends = git
+ provides = spl-utils
+ conflicts = spl-utils-common
+ conflicts = spl-utils-linux-git
+ conflicts = spl-utils-linux
+ conflicts = spl-utils-linux-lts
+ conflicts = spl-utils-linux-lts-git
+ replaces = spl-utils-linux,
+ replaces = spl-utils-linux-lts
+ source = git+https://github.com/zfsonlinux/spl.git
+ sha256sums = SKIP
+
+pkgname = spl-utils-common-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2739fcdc4659
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log
+spl/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..815d351001f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+#
+pkgname="spl-utils-common-git"
+pkgver=0.7.0_rc5_r0_gae42190
+pkgrel=1
+pkgdesc="Solaris Porting Layer kernel module support files."
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("git+https://github.com/zfsonlinux/spl.git")
+sha256sums=("SKIP")
+groups=("archzfs-linux-git")
+license=("GPL")
+provides=("spl-utils")
+makedepends=("git")
+conflicts=('spl-utils-common' 'spl-utils-linux-git' 'spl-utils-linux' 'spl-utils-linux-lts' 'spl-utils-linux-lts-git')
+replaces=("spl-utils-linux", "spl-utils-linux-lts")
+
+build() {
+ cd "${srcdir}/spl"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin --with-config=user
+ make
+}
+
+package() {
+ cd "${srcdir}/spl"
+ make DESTDIR="${pkgdir}" install
+}