summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2016-04-21 01:43:26 -0700
committerJesus Alvarez2016-04-21 01:43:26 -0700
commitaf303efa6a82a344c9e6937232a453f6718950cd (patch)
tree917a7515b7d1c7ebe84611b9567f7ba2914d0755
downloadaur-af303efa6a82a344c9e6937232a453f6718950cd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD43
-rw-r--r--spl-utils.hostid1
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cb8094e8ca3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Apr 21 08:40:44 UTC 2016
+pkgbase = spl-utils-linux-git
+ pkgdesc = Solaris Porting Layer kernel module support files.
+ pkgver = 0.6.5_r49_g224817e_4.5.1_1
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ arch = x86_64
+ groups = archzfs-linux-git
+ license = GPL
+ makedepends = git
+ provides = spl-utils-linux-git
+ source = git+https://github.com/zfsonlinux/spl.git
+ source = spl-utils.hostid
+ sha256sums = SKIP
+ sha256sums = ad95131bc0b799c0b1af477fb14fcf26a6a9f76079e48bf090acb7e8367bfd0e
+
+pkgname = spl-utils-linux-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2739fcdc4659
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log
+spl/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc70c4a6666d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux packages will only work with the default package! To have a single PKGBUILD target many kernels
+# would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgname="spl-utils-linux-git"
+pkgver=0.6.5_r49_g224817e_4.5.1_1
+pkgrel=1
+pkgdesc="Solaris Porting Layer kernel module support files."
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("git+https://github.com/zfsonlinux/spl.git"
+ "spl-utils.hostid")
+sha256sums=("SKIP"
+ "ad95131bc0b799c0b1af477fb14fcf26a6a9f76079e48bf090acb7e8367bfd0e")
+groups=("archzfs-linux-git")
+license=("GPL")
+provides=("spl-utils-linux-git")
+makedepends=("git")
+
+build() {
+ cd "${srcdir}/spl"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin --with-config=user
+ make
+}
+
+package() {
+ cd "${srcdir}/spl"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}"/spl-utils.hostid "${pkgdir}"/etc/hostid
+}
diff --git a/spl-utils.hostid b/spl-utils.hostid
new file mode 100644
index 000000000000..7bde8641b93c
--- /dev/null
+++ b/spl-utils.hostid
@@ -0,0 +1 @@
+ÿÿÿÿ \ No newline at end of file