summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alvarez2017-06-14 19:24:13 -0700
committerJesus Alvarez2017-06-14 19:24:13 -0700
commitc30ee524359caa62b081a6d95b18d99faf7de4bd (patch)
tree485fb182217259c02cf24b6638d03120cf0a3b53
downloadaur-c30ee524359caa62b081a6d95b18d99faf7de4bd.tar.gz
Initial commit for kernel 4.9.31_1-1
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD42
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6636535e3533
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Jun 15 02:16:33 UTC 2017
+pkgbase = spl-utils-linux-lts-git
+ pkgdesc = Solaris Porting Layer kernel module support files.
+ pkgver = 0.7.0_rc4_r4_gac48361_4.9.31_1
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ arch = x86_64
+ groups = archzfs-linux-lts-git
+ license = GPL
+ makedepends = linux-lts-headers=4.9.31-1
+ makedepends = git
+ provides = spl-utils
+ conflicts = spl-utils-linux
+ conflicts = spl-utils-linux-git
+ conflicts = spl-utils-linux-lts
+ source = git+https://github.com/zfsonlinux/spl.git
+ sha256sums = SKIP
+
+pkgname = spl-utils-linux-lts-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2739fcdc4659
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log
+spl/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..554630668e02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-lts packages will only work with the default linux-lts package! To have a single PKGBUILD target
+# many kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+#
+pkgname="spl-utils-linux-lts-git"
+pkgver=0.7.0_rc4_r4_gac48361_4.9.31_1
+pkgrel=1
+pkgdesc="Solaris Porting Layer kernel module support files."
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("git+https://github.com/zfsonlinux/spl.git")
+sha256sums=("SKIP")
+groups=("archzfs-linux-lts-git")
+license=("GPL")
+provides=("spl-utils")
+makedepends=("linux-lts-headers=4.9.31-1" "git")
+conflicts=('spl-utils-linux' 'spl-utils-linux-git' 'spl-utils-linux-lts')
+
+build() {
+ cd "${srcdir}/spl"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin --with-config=user
+ make
+}
+
+package() {
+ cd "${srcdir}/spl"
+ make DESTDIR="${pkgdir}" install
+}