summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Niesen2021-10-26 11:26:10 +0200
committerLars Niesen2021-10-26 11:26:10 +0200
commit03dc46981c7b8d5b2c57174d97fce7275c2a7a89 (patch)
tree5bb6e6a6fc3453e771f64b3cde4d971f73a7d9d3
downloadaur-03dc46981c7b8d5b2c57174d97fce7275c2a7a89.tar.gz
added PKGBUIDL and .SRINFO for the splan-notify pagage
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c49c530f3833
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = splan-notify-git
+ pkgdesc = Easily get Notifications from the StarPlaner timetables
+ pkgver = 1.0.r1.g1c6718f
+ pkgrel = 1
+ url = https://github.com/TripleTrable/splan-notify
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = curl
+ depends = awk
+ depends = libnotify
+ depends = grep
+ source = git+https://github.com/TripleTrable/splan-notify
+ md5sums = SKIP
+
+pkgname = splan-notify-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c78509fd515
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lars Niesen <lars.niesen@gmx.de>
+pkgname=splan-notify-git
+_name="${pkgname%-git}"
+pkgver() { git -C "$_name" describe --tags | sed 's/^v//;s/-/.r/;s/-/./g'; }
+pkgver=1.0.r1.g1c6718f
+pkgrel=1
+
+pkgdesc="Easily get Notifications from the StarPlaner timetables"
+arch=('any')
+url="https://github.com/TripleTrable/$_name"
+license=('MIT')
+depends=('curl' 'awk' 'libnotify' 'grep')
+makedepends=('git')
+source=("git+$url")
+md5sums=('SKIP')
+
+build() {
+ cd "$_name"
+ make ttParser
+}
+
+package() {
+ cd "$_name"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}