summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2015-08-12 20:52:51 +0200
committerSibren Vasse2015-08-12 20:52:51 +0200
commit9064e5e5bb19ca782a38a9711f9b03c7b834d86e (patch)
tree4dbc2ac01ce088c9ad42810faefe8d30920d0968
downloadaur-9064e5e5bb19ca782a38a9711f9b03c7b834d86e.tar.gz
Initial import to aur4
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD35
-rwxr-xr-xsplashtop-streamer3
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c31f1323439
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = splashtop-streamer
+ pkgdesc = Remotely access your desktop from any device from anywhere! - Server version
+ pkgver = 2.2.5.1
+ pkgrel = 4
+ url = http://www.splashtop.com/streamer/linux
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = curl
+ makedepends = p7zip
+ depends = python2
+ depends = pywebkitgtk
+ depends = python2-keyring
+ depends = python2-crypto
+ depends = apr
+ depends = apr-util
+ depends = dbus
+ depends = dbus-glib
+ depends = glib2
+ depends = libpulse
+ depends = openssl
+ depends = util-linux
+ depends = libx11
+ depends = libx264
+ depends = libxfixes
+ depends = libxrandr
+ depends = libxtst
+ depends = libappindicator-gtk2
+ depends = networkmanager
+ source = http://d17kmd0va0f0mp.cloudfront.net/linux/Splashtop_Streamer_Ubuntu_14.04_v2.2.5.1-4_i386.deb
+ source = splashtop-streamer
+ md5sums = d9806b33adeb6ea11a6e992f513b9e83
+ md5sums = 9867062d727d41fff1ba47cf9bc501a1
+
+pkgname = splashtop-streamer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18bab20f2e60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sibren Vasse <arch at sibrenvasse dot nl>
+pkgname=splashtop-streamer
+pkgver=2.2.5.1
+pkgrel=4
+pkgdesc="Remotely access your desktop from any device from anywhere! - Server version"
+arch=('x86_64' 'i686')
+url="http://www.splashtop.com/streamer/linux"
+license=('custom')
+depends=('python2' 'pywebkitgtk' 'python2-keyring' 'python2-crypto' 'apr' 'apr-util' 'dbus' 'dbus-glib' 'glib2' 'libpulse' 'openssl' 'util-linux' 'libx11' 'libx264' 'libxfixes' 'libxrandr' 'libxtst' 'libappindicator-gtk2' 'networkmanager')
+makedepends=('curl' 'p7zip')
+if [ "$CARCH" = "x86_64" ]; then
+ source=(http://d17kmd0va0f0mp.cloudfront.net/linux/Splashtop_Streamer_Ubuntu_14.04_v${pkgver}-${pkgrel}_amd64.deb
+ splashtop-streamer)
+ md5sums=('d56f08bb08b0a58b65c64bd3a8f7a4b4'
+ '9867062d727d41fff1ba47cf9bc501a1')
+else
+ source=(http://d17kmd0va0f0mp.cloudfront.net/linux/Splashtop_Streamer_Ubuntu_14.04_v${pkgver}-${pkgrel}_i386.deb
+ splashtop-streamer)
+ md5sums=('d9806b33adeb6ea11a6e992f513b9e83'
+ '9867062d727d41fff1ba47cf9bc501a1')
+fi
+
+package ()
+{
+ msg "Extracting Splashtop package"
+ #cd "$srcdir/$pkgname-$pkgver"
+ tar -xf $srcdir/data.tar.xz -C $pkgdir
+ sed -i 's/python /python2 /' $pkgdir/usr/share/applications/SplashtopStreamer.desktop
+
+ msg "Creating custom executable in /usr/bin"
+ mkdir -p $pkgdir/usr/bin
+ cp splashtop-streamer $pkgdir/usr/bin/
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/splashtop-streamer b/splashtop-streamer
new file mode 100755
index 000000000000..f5cb4d4904c5
--- /dev/null
+++ b/splashtop-streamer
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+python2 /opt/splashtop-streamer/SRStreamer.pyc