summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2022-04-03 01:40:06 -0400
committergraysky2022-04-03 01:40:06 -0400
commitc41dfb1e8865fde5254e0628b6163f9d398ba3f2 (patch)
treec75deaa85b9e0e98474c94c1f900fc2949ce07ff
parent224f285770b57ecadbbfad35a10e1ce4ef0c97d3 (diff)
downloadaur-c41dfb1e8865fde5254e0628b6163f9d398ba3f2.tar.gz
Update to 20200508-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
2 files changed, 31 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9966cf108b5d..9a018b1b3ad7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = split2flac
pkgdesc = Split flac/ape/wv/wav + cue sheet into separate tracks.
- pkgver = 122
+ pkgver = 20200508
pkgrel = 1
url = https://github.com/ftrvxmtrx/split2flac
arch = any
@@ -13,17 +13,17 @@ pkgbase = split2flac
optdepends = faac: to split into m4a
optdepends = flac: for flac replay gain support
optdepends = mac: to split APE format
- optdepends = id3lib: to set tags in mp3 (unicode not supported)
+ optdepends = id3lib: to set tags in mp3 unicode not supported
optdepends = imagemagick: to convert/resize album cover images
optdepends = lame: to split into mp3
optdepends = libmp4v2: to split into m4a
optdepends = mp3gain: mp3 volume normalization
- optdepends = python-mutagen: to set tags in mp3 (with unicode support)
+ optdepends = python-mutagen: mp3 with unicode support within tags
optdepends = vorbis-tools: to split into ogg vorbis
optdepends = vorbisgain: ogg vorbis volume normalization
optdepends = wavpack: to split WV
- conflicts = split2flac-git
- source = https://github.com/ftrvxmtrx/split2flac/archive/122.tar.gz
- sha256sums = 96dd53c92935ae6cb1650bf92f989658d7909b691bbec12b639736f79f5b639c
+ replaces = split2flac-git
+ source = split2flac-491591d.tar.gz::https://github.com/ftrvxmtrx/split2flac/archive/491591d21e2f97419e74751864b76b234b0fa2f1.tar.gz
+ b2sums = 65c31516835721b8bd4e554feb300e95bc07eee0b453da6245982f1211bd5ceb7f64e8e7d58b8f640d2b41e312f9b98e8ce3fbb863a1f6b19457a5d908153e5e
pkgname = split2flac
diff --git a/PKGBUILD b/PKGBUILD
index 79fa8bea9532..a672266c0088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,37 @@
# Contributer: Serge Ziryukin <ftrvxmtrx@gmail.com>
pkgname=split2flac
-pkgver=122
+# upstream has gone read-only and this is the last commit
+_commit=491591d21e2f97419e74751864b76b234b0fa2f1
+pkgver=20200508
pkgrel=1
pkgdesc="Split flac/ape/wv/wav + cue sheet into separate tracks."
-arch=('any')
+arch=(any)
url="https://github.com/ftrvxmtrx/split2flac"
-license=('MIT')
-depends=('cuetools' 'shntool' 'flac')
-conflicts=('split2flac-git')
-optdepends=('aacgain-cvs: to adjust gain in m4a'
-'enca: to automatically detect charset if not UTF8'
-'faac: to split into m4a'
-'flac: for flac replay gain support'
-'mac: to split APE format'
-'id3lib: to set tags in mp3 (unicode not supported)'
-'imagemagick: to convert/resize album cover images'
-'lame: to split into mp3'
-'libmp4v2: to split into m4a'
-'mp3gain: mp3 volume normalization'
-'python-mutagen: to set tags in mp3 (with unicode support)'
+license=(MIT)
+depends=(cuetools shntool flac)
+replaces=(split2flac-git)
+eonflicts=(split2flac-git)
+optdepends=(
+'aacgain-cvs: to adjust gain in m4a'
+'enca: to automatically detect charset if not UTF8'
+'faac: to split into m4a'
+'flac: for flac replay gain support'
+'mac: to split APE format'
+'id3lib: to set tags in mp3 unicode not supported'
+'imagemagick: to convert/resize album cover images'
+'lame: to split into mp3'
+'libmp4v2: to split into m4a'
+'mp3gain: mp3 volume normalization'
+'python-mutagen: mp3 with unicode support within tags'
'vorbis-tools: to split into ogg vorbis'
-'vorbisgain: ogg vorbis volume normalization'
-'wavpack: to split WV')
-source=("https://github.com/ftrvxmtrx/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('96dd53c92935ae6cb1650bf92f989658d7909b691bbec12b639736f79f5b639c')
+'vorbisgain: ogg vorbis volume normalization'
+'wavpack: to split WV')
+source=("$pkgname-${_commit:0:7}.tar.gz::https://github.com/ftrvxmtrx/$pkgname/archive/$_commit.tar.gz")
+b2sums=('65c31516835721b8bd4e554feb300e95bc07eee0b453da6245982f1211bd5ceb7f64e8e7d58b8f640d2b41e312f9b98e8ce3fbb863a1f6b19457a5d908153e5e')
package () {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_commit"
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm755 $pkgname-bash-completion.sh \
"$pkgdir/usr/share/bash-completion/completions/$pkgname-bash-completion.sh"