summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaansu2015-08-25 15:52:52 -0700
committerRaansu2015-08-25 15:52:52 -0700
commit62479f192112a5c73cdc7fef1e7c8f9c05a17acc (patch)
tree5eeb37274ff0568c2f7ac1e823ff656ff0d3b687
downloadaur-62479f192112a5c73cdc7fef1e7c8f9c05a17acc.tar.gz
Inital upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f40f95d18063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = splitviewfuse
+ pkgdesc = A view on a given directory that splits large files into segments implemented as FUSE file system. An additional filesystem that merges such segments into regular files is included as well. AUR package by Raansu, project by seiferma
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/seiferma/splitviewfuse
+ arch = any
+ license = MIT
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = fuse
+ depends = python2-fusepy
+ provides = splitviewfuse
+ provides = unionviewfuse
+ conflicts = splitviewfuse-git
+ conflicts = splitviewfuse
+ conflicts = unionviewfuse
+ source = https://github.com/seiferma/splitviewfuse/archive/v0.2.2.tar.gz
+ sha256sums = dae6806c227d06296f251237d89ad6886a567681842b948fd8f6500cc96a0108
+
+pkgname = splitviewfuse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..273b414a6b76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer of AUR package: Raansu <gero3977@gmail.com>
+# Maintainer of splitviewfuse project: seiferma <https://github.com/seiferma>
+pkgname=splitviewfuse
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="A view on a given directory that splits large files into segments implemented as FUSE file system. An additional filesystem that merges such segments into regular files is included as well. AUR package by Raansu, project by seiferma"
+arch=('any')
+url="https://github.com/seiferma/splitviewfuse"
+license=('MIT')
+depends=('fuse' 'python2-fusepy')
+makedepends=('python2' 'python2-setuptools')
+provides=('splitviewfuse' 'unionviewfuse')
+conflicts=('splitviewfuse-git' 'splitviewfuse' 'unionviewfuse')
+source=("https://github.com/seiferma/splitviewfuse/archive/v$pkgver.tar.gz")
+sha256sums=('dae6806c227d06296f251237d89ad6886a567681842b948fd8f6500cc96a0108')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}