summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL. Bradley LaBoon2016-01-15 18:21:28 -0500
committerL. Bradley LaBoon2016-01-15 18:21:28 -0500
commit6e39190f6132bbb9b5a265d31b290a72ef03887f (patch)
treecf101b3500946f11a5e56c2ace7da75d673c778a
parentec16c1663ee10d9299566da825a4bf119ade376b (diff)
downloadaur-6e39190f6132bbb9b5a265d31b290a72ef03887f.tar.gz
Updated PKGBUILD to use proper variables
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f99fcfd75ffb..c364e8943497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Dec 28 21:41:10 UTC 2015
+# Fri Jan 15 23:20:49 UTC 2016
pkgbase = splunk
pkgdesc = Statistical analysis and search tool for logs and machine data
pkgver = 6.3.2_aaff59bb082c
@@ -9,10 +9,14 @@ pkgbase = splunk
arch = x86_64
arch = i686
license = custom
- source = http://download.splunk.com/products/splunk/releases/6.3.2/splunk/linux/splunk-6.3.2-aaff59bb082c-Linux-.tgz
- source = splunk.service
- sha256sums = e82566e56c1872c32f4f2fec4751476455bd06251794eb88dcbbe5cb37b0c647
- sha256sums = ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757
+ source_x86_64 = http://download.splunk.com/products/splunk/releases/6.3.2/splunk/linux/splunk-6.3.2-aaff59bb082c-Linux-x86_64.tgz
+ source_x86_64 = splunk.service
+ sha256sums_x86_64 = e82566e56c1872c32f4f2fec4751476455bd06251794eb88dcbbe5cb37b0c647
+ sha256sums_x86_64 = ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757
+ source_i686 = http://download.splunk.com/products/splunk/releases/6.3.2/splunk/linux/splunk-6.3.2-aaff59bb082c-Linux-i686.tgz
+ source_i686 = splunk.service
+ sha256sums_i686 = b2ba9fe5e3666d454737c960d25ae0b4e74423f68ddc62b4c280c337355143f3
+ sha256sums_i686 = ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757
pkgname = splunk
diff --git a/PKGBUILD b/PKGBUILD
index dc036fe16a17..dd97cd72d285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,22 @@ url="http://www.splunk.com/"
arch=('x86_64' 'i686')
license=('custom')
install="$pkgname.install"
-source=(
- "http://download.splunk.com/products/splunk/releases/6.3.2/splunk/linux/$pkgname-${pkgver//_/-}-Linux-$CARCH.tgz"
+source_i686=(
+ "http://download.splunk.com/products/splunk/releases/6.3.2/splunk/linux/$pkgname-${pkgver//_/-}-Linux-i686.tgz"
"$pkgname.service"
)
-if [ $CARCH == 'i686' ]; then
- sha256sums=(
- 'b2ba9fe5e3666d454737c960d25ae0b4e74423f68ddc62b4c280c337355143f3'
- 'ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757'
- )
-else
- sha256sums=(
- 'e82566e56c1872c32f4f2fec4751476455bd06251794eb88dcbbe5cb37b0c647'
- 'ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757'
- )
-fi
+source_x86_64=(
+ "http://download.splunk.com/products/splunk/releases/6.3.2/splunk/linux/$pkgname-${pkgver//_/-}-Linux-x86_64.tgz"
+ "$pkgname.service"
+)
+sha256sums_i686=(
+ 'b2ba9fe5e3666d454737c960d25ae0b4e74423f68ddc62b4c280c337355143f3'
+ 'ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757'
+)
+sha256sums_x86_64=(
+ 'e82566e56c1872c32f4f2fec4751476455bd06251794eb88dcbbe5cb37b0c647'
+ 'ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757'
+)
package() {
cd "$srcdir"