summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL. Bradley LaBoon2019-09-21 18:07:08 -0400
committerL. Bradley LaBoon2019-09-21 18:07:08 -0400
commitbb8c6f1a57b76cb67f131d4f2c7e57e50f488800 (patch)
treec48b4e0ae15778946bb70f16b463623de168546d
parent1f658bbe27fd5c9d7288f184db6aa35c3c78a5aa (diff)
downloadaur-bb8c6f1a57b76cb67f131d4f2c7e57e50f488800.tar.gz
Updated to version 7.3.1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5483eedd803a..223048d78a6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = splunk
pkgdesc = Statistical analysis and search tool for logs and machine data
- pkgver = 7.3.1_bd63e13aa157
+ pkgver = 7.3.1.1
pkgrel = 1
- epoch = 2
+ epoch = 3
url = https://www.splunk.com/
install = splunk.install
arch = x86_64
license = custom
source = splunk.service
sha256sums = ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757
- source_x86_64 = https://download.splunk.com/products/splunk/releases/7.3.1/linux/splunk-7.3.1-bd63e13aa157-Linux-x86_64.tgz
- sha256sums_x86_64 = d5cd5e8680b7a2fd75c315c57ffc8abbe19f1057792d0f7a739193315304e25a
+ source_x86_64 = https://download.splunk.com/products/splunk/releases/7.3.1.1/linux/splunk-7.3.1.1-7651b7244cf2-Linux-x86_64.tgz
+ sha256sums_x86_64 = c24f421161266fc6b79f3e5374534f97662a3b9659bec261f8633b5a35d7a20c
pkgname = splunk
diff --git a/PKGBUILD b/PKGBUILD
index 2a1c15a6dcdb..a78b810212db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: L. Bradley LaBoon <me@bradleylaboon.com>
pkgname=splunk
-basever=7.3.1
-pkgver=${basever}_bd63e13aa157
+basever=7.3.1.1
+splunkver=${basever}-7651b7244cf2
+# Splunk is inconsistent with the length of their version numbers
+if [ ${#basever} -gt 5 ]; then
+ pkgver=${basever}
+else
+ pkgver=${basever}.0
+fi
pkgrel=1
-epoch=2
+epoch=3
pkgdesc="Statistical analysis and search tool for logs and machine data"
url="https://www.splunk.com/"
arch=('x86_64')
license=('custom')
install="$pkgname.install"
source=("$pkgname.service")
-source_x86_64=("https://download.splunk.com/products/splunk/releases/$basever/linux/$pkgname-${pkgver//_/-}-Linux-x86_64.tgz")
+source_x86_64=("https://download.splunk.com/products/splunk/releases/$basever/linux/$pkgname-$splunkver-Linux-x86_64.tgz")
sha256sums=('ca96b85750a0592208facc747bbe1eb22b0a35b6dee841e6f51f1ad6a9157757')
-sha256sums_x86_64=('d5cd5e8680b7a2fd75c315c57ffc8abbe19f1057792d0f7a739193315304e25a')
+sha256sums_x86_64=('c24f421161266fc6b79f3e5374534f97662a3b9659bec261f8633b5a35d7a20c')
package() {
cd "$srcdir"