summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMittens2016-07-16 21:48:38 -0700
committerMittens2016-07-16 21:48:38 -0700
commit6f495e39e74593699db4ee2666463505defa0990 (patch)
tree0135aa2e93d0d4648b51ac6b3ccec4a82afc0597
downloadaur-6f495e39e74593699db4ee2666463505defa0990.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75a44ad728b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = spm
+ pkgdesc = simple password manager, a fork of nmeum's tpm
+ pkgver = 1.4.5
+ pkgrel = 1
+ url = https://notabug.org/kl3/spm
+ arch = any
+ license = GPL
+ depends = gnupg
+ source = https://notabug.org/kl3/spm/archive/1.4.5.tar.gz
+ sha256sums = 7f2d31391697deb71b43d612199cc281f07ca5640484bb64fe94911912635d84
+
+pkgname = spm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56fcacf318f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Mittens2001 <mittens2001@opmbx.org>
+
+pkgname=spm
+pkgver=1.4.5
+pkgrel=1
+pkgdesc="simple password manager, a fork of nmeum's tpm"
+arch=('any')
+url="https://notabug.org/kl3/spm"
+license=('GPL')
+depends=('gnupg')
+source=("https://notabug.org/kl3/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('7f2d31391697deb71b43d612199cc281f07ca5640484bb64fe94911912635d84')
+
+package() {
+ cd "$srcdir"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/license/$pkgname/LICENSE"
+}