summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-12 22:26:23 +0200
committerGoliathLabs2020-05-12 22:26:23 +0200
commit887bfab00193ffbf592692179c5cc0d301749126 (patch)
tree4b8cd5e59f452375344dc8e327723c2d25085c3f
parentbe9cce7ba363947a370337a53a3f2e75f38de00a (diff)
downloadaur-887bfab00193ffbf592692179c5cc0d301749126.tar.gz
Updated: nginx 1.18.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c55b7caf8f9..18c2066e311f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Feb 26 18:38:18 UTC 2018
pkgbase = spnego-http-auth-nginx-module-git
pkgdesc = Dynamic Nginx module for SPNEGO Kerberos authentication via GSSAPI
- pkgver = 1.13.9.7e028a5
+ pkgver = 1.18.0.72c8ee0
pkgrel = 1
url = https://github.com/stnoonan/spnego-http-auth-nginx-module
arch = x86_64
@@ -10,10 +8,11 @@ pkgbase = spnego-http-auth-nginx-module-git
depends = nginx
depends = krb5
source = spnego-http-auth-nginx-module-git::git+https://github.com/stnoonan/spnego-http-auth-nginx-module.git
- source = https://nginx.org/download/nginx-1.13.9.tar.gz
- source = https://nginx.org/download/nginx-1.13.9.tar.gz.asc
- sha256sums = SKIP
+ source = https://nginx.org/download/nginx-1.18.0.tar.gz
+ source = https://nginx.org/download/nginx-1.18.0.tar.gz.asc
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
sha256sums = SKIP
+ sha256sums = 4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99
sha256sums = SKIP
pkgname = spnego-http-auth-nginx-module-git
diff --git a/PKGBUILD b/PKGBUILD
index 84a4f865b5f4..03618181c03d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
-# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Gavin Lloyd <gavinhungry@gmail.com>
-_module=spnego-http-auth-nginx-module
-_nginx=$(command -v nginx > /dev/null && nginx -v 2>&1 | awk -F'nginx/' '{print $NF}')
-
-pkgname=${_module}-git
-pkgver=1.13.9.7e028a5
+_pkgname=spnego-http-auth-nginx-module
+pkgname=${_pkgname}-git
+pkgver=1.18.0.72c8ee0
+_nginxver=1.18.0
pkgrel=1
pkgdesc='Dynamic Nginx module for SPNEGO Kerberos authentication via GSSAPI'
arch=('x86_64')
url='https://github.com/stnoonan/spnego-http-auth-nginx-module'
license=('BSD')
depends=('nginx' 'krb5')
-source=("${pkgname}::git+https://github.com/stnoonan/${_module}.git"
- "https://nginx.org/download/nginx-${_nginx}.tar.gz"
- "https://nginx.org/download/nginx-${_nginx}.tar.gz.asc")
+source=("${pkgname}::git+https://github.com/stnoonan/${_pkgname}.git"
+ "https://nginx.org/download/nginx-${_nginxver}.tar.gz"
+ "https://nginx.org/download/nginx-${_nginxver}.tar.gz.asc")
sha256sums=('SKIP'
- 'SKIP'
+ '4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99'
'SKIP')
validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8') # Maxim Dounin <mdounin@mdounin.ru>
pkgver() {
cd "${srcdir}/${pkgname}"
- echo "${_nginx}".$(git rev-parse --short HEAD)
+ echo "${_nginxver}".$(git rev-parse --short HEAD)
}
build() {
- cd "${srcdir}/nginx-${_nginx}"
+ cd "${srcdir}/nginx-${_nginxver}"
./configure --with-compat --add-dynamic-module=../"${pkgname}"
make modules
}
package() {
cd "${srcdir}"
- install -Dm755 "nginx-${_nginx}"/objs/ngx_http_auth_spnego_module.so "${pkgdir}"/usr/lib/nginx/modules/ngx_http_auth_spnego_module.so
+ install -Dm755 "nginx-${_nginxver}"/objs/ngx_http_auth_spnego_module.so "${pkgdir}"/usr/lib/nginx/modules/ngx_http_auth_spnego_module.so
install -Dm644 "${pkgname}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}