summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2018-02-26 10:36:03 -0800
committerGavin Lloyd2018-02-26 10:36:03 -0800
commitc8054c1a4e04a319b42dcf94f7c163ebd7c34222 (patch)
treea57bd6f4af6f6d27655bc62960e1518edc37f4b4
downloadaur-c8054c1a4e04a319b42dcf94f7c163ebd7c34222.tar.gz
Init commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7813c76b5fdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Feb 26 18:35:57 UTC 2018
+pkgbase = spnego-http-auth-nginx-module-git
+ pkgdesc = Dynamic Nginx module for SPNEGO Kerberos authentication via GSSAPI
+ pkgver = 1.13.7.7e028a5
+ pkgrel = 1
+ url = https://github.com/stnoonan/spnego-http-auth-nginx-module
+ arch = x86_64
+ license = BSD
+ depends = nginx
+ depends = krb5
+ source = spnego-http-auth-nginx-module-git::git+https://github.com/stnoonan/spnego-http-auth-nginx-module.git
+ source = https://nginx.org/download/nginx-1.13.9.tar.gz
+ source = https://nginx.org/download/nginx-1.13.9.tar.gz.asc
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = spnego-http-auth-nginx-module-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f78fe1356827
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+_module=spnego-http-auth-nginx-module
+_nginx=$(command -v nginx > /dev/null && nginx -v 2>&1 | awk -F'nginx/' '{print $NF}')
+
+pkgname=${_module}-git
+pkgver=1.13.7.7e028a5
+pkgrel=1
+pkgdesc='Dynamic Nginx module for SPNEGO Kerberos authentication via GSSAPI'
+arch=('x86_64')
+url='https://github.com/stnoonan/spnego-http-auth-nginx-module'
+license=('BSD')
+depends=('nginx' 'krb5')
+source=("${pkgname}::git+https://github.com/stnoonan/${_module}.git"
+ "https://nginx.org/download/nginx-${_nginx}.tar.gz"
+ "https://nginx.org/download/nginx-${_nginx}.tar.gz.asc")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8') # Maxim Dounin <mdounin@mdounin.ru>
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "${_nginx}".$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/nginx-${_nginx}"
+ ./configure --with-compat --add-dynamic-module=../"${pkgname}"
+ make modules
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 "nginx-${_nginx}"/objs/ngx_http_auth_spnego_module.so "${pkgdir}"/usr/lib/nginx/modules/ngx_http_auth_spnego_module.so
+ install -Dm644 "${pkgname}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}