summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaahilNotSahil2024-04-01 20:43:21 +0000
committerSaahilNotSahil2024-04-01 20:43:21 +0000
commit6d5356c92f629eeeed231864a4abbf5e1ae603e7 (patch)
treeb5b1d0ca24711bee7b160195b34bd15c64ea1402
downloadaur-6d5356c92f629eeeed231864a4abbf5e1ae603e7.tar.gz
Update to 0.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49867d75a612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spok-bin
+ pkgdesc = Sans Password or Key (SPoK) - An easier way for remote server authentication
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/devlup-labs/spok
+ license = MIT
+ conflicts = spok
+ provides = spok
+ arch = aarch64
+ source_aarch64 = https://github.com/devlup-labs/spok/releases/download/0.1.0/spok_0.1.0_linux_arm64.tar.gz
+ sha256sums_aarch64 = 0b31543f68d88325a669d900a16a584e600fe543594ba9772a86f4af2b753202
+ arch = x86_64
+ source_x86_64 = https://github.com/devlup-labs/spok/releases/download/0.1.0/spok_0.1.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = ada1340486fa7c294b08f116eb9cb74df50f3e48c5d9430ce2cdd156ba952894
+
+pkgname = spok-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24bde1de79e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Saahil Bhavsar <saahil_bhavsar@outlook.com>
+# Contributor: Saahil Bhavsar <saahil_bhavsar@outlook.com>
+# Contributor: Jyotin Goel <b22ai063@iitj.ac.in>
+
+pkgname='spok-bin'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Sans Password or Key (SPoK) - An easier way for remote server authentication'
+url='https://github.com/devlup-labs/spok'
+arch=('aarch64' 'x86_64')
+license=('MIT')
+provides=('spok')
+conflicts=('spok')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/devlup-labs/spok/releases/download/0.1.0/spok_0.1.0_linux_arm64.tar.gz")
+sha256sums_aarch64=('0b31543f68d88325a669d900a16a584e600fe543594ba9772a86f4af2b753202')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/devlup-labs/spok/releases/download/0.1.0/spok_0.1.0_linux_amd64.tar.gz")
+sha256sums_x86_64=('ada1340486fa7c294b08f116eb9cb74df50f3e48c5d9430ce2cdd156ba952894')
+
+package() {
+ install -Dm755 "./bin/spok" "${pkgdir}/usr/bin/spok"
+ install -Dm755 "./scripts/configure-spok-server.sh" "${pkgdir}/etc/spok/scripts/configure-spok-server.sh"
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/spok/LICENSE"
+ install -Dm644 "./README.md" "${pkgdir}/usr/share/doc/spok/README.md"
+}