summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Leddin2020-10-13 21:35:58 +0200
committerLaura Leddin2020-10-13 21:35:58 +0200
commitdff31177f85d62b159b8312852d3746db47e2cb1 (patch)
tree6c9575b34414419f083b1125e00e3e45bfa34404
downloadaur-dff31177f85d62b159b8312852d3746db47e2cb1.tar.gz
Add srcinfo, pkgbuild and gitignore files
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD46
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd9a3842b8f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sponge-case-git
+ pkgdesc = Converts strings to spongebob mocking case
+ pkgver = v1.0.0_3_gee8dab4
+ pkgrel = 1
+ url = https://github.com/FabianTe/sponge-case
+ arch = x86_64
+ makedepends = git
+ makedepends = go-pie
+ provides = sponge-case
+ source = git+https://github.com/FabianTe/sponge-case.git
+ md5sums = SKIP
+
+pkgname = sponge-case-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5e7a56d862e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Laura Leddin <laura+aur@llaura.de>
+_pkgname=sponge-case
+pkgname=sponge-case-git
+pkgver=v1.0.0_3_gee8dab4
+pkgrel=1
+epoch=
+pkgdesc="Converts strings to spongebob mocking case"
+arch=('x86_64')
+url="https://github.com/FabianTe/sponge-case"
+license=()
+groups=()
+depends=()
+makedepends=('git'
+ 'go-pie')
+checkdepends=()
+optdepends=()
+provides=('sponge-case')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/FabianTe/sponge-case.git")
+noextract=()
+validpgpkeys=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags --long | sed s/-/_/g
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ go build -o "${srcdir}/pkg/sponge-case"
+}
+
+package() {
+ install -Dm755 "${srcdir}/pkg/sponge-case" -t "${pkgdir}/usr/bin/"
+}