summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2021-07-14 01:01:44 +0200
committerAngelo Theodorou2021-07-14 01:01:44 +0200
commit7645a2be4d18bb2591ad4a81e5feae5056090d91 (patch)
treeaedda072929120b667272e67dfd1a5e27c5cb70c
parentf62d6edaf233c2808513a9dd5dfbe5af16ea99df (diff)
downloadaur-7645a2be4d18bb2591ad4a81e5feae5056090d91.tar.gz
Update CMake variables for new template scripts
- Change git describe command for pkgver function
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 993b5fa1204b..4d1f9841c20d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spookyghost-git
pkgdesc = A procedural sprite animation tool made with the nCine
- pkgver = r58.afb50fd
+ pkgver = r61.9dbecea
pkgrel = 1
url = https://encelo.itch.io/spookyghost
arch = i686
@@ -20,4 +20,3 @@ pkgbase = spookyghost-git
md5sums = SKIP
pkgname = spookyghost-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 100f7464b685..977ec922969d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Angelo Theodorou <encelo@gmail.com>
pkgname=spookyghost-git
-pkgver=r58.afb50fd
+pkgver=r61.9dbecea
pkgrel=1
pkgdesc="A procedural sprite animation tool made with the nCine"
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/SpookyGhost"
( set -o pipefail
- git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --tags --long --exact-match 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
@@ -46,11 +46,11 @@ build() {
cmake ../SpookyGhost\
-DCMAKE_BUILD_TYPE=Release\
-DnCine_DIR=$PWD/../nCine-build\
- -DPACKAGE_BUILD_ANDROID=OFF\
- -DPACKAGE_STRIP_BINARIES=ON\
- -DPACKAGE_DEFAULT_DATA_DIR=/usr/share/spookyghost/data\
+ -DNCPROJECT_BUILD_ANDROID=OFF\
+ -DNCPROJECT_STRIP_BINARIES=ON\
+ -DNCPROJECT_DEFAULT_DATA_DIR=/usr/share/spookyghost/data\
-DCMAKE_INSTALL_PREFIX=/usr\
- -DCUSTOM_ITCHIO_BUILD=OFF
+ -DCUSTOM_ITCHIO_BUILD=OFF
make
}