summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2021-05-24 14:27:01 +0200
committerAngelo Theodorou2021-05-24 14:27:01 +0200
commitf62d6edaf233c2808513a9dd5dfbe5af16ea99df (patch)
treea282eb650347d1a379e61c8b93d36f1ae0d65090
downloadaur-f62d6edaf233c2808513a9dd5dfbe5af16ea99df.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..993b5fa1204b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = spookyghost-git
+ pkgdesc = A procedural sprite animation tool made with the nCine
+ pkgver = r58.afb50fd
+ pkgrel = 1
+ url = https://encelo.itch.io/spookyghost
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = glew
+ depends = libpng
+ depends = sdl2
+ depends = lua
+ depends = hicolor-icon-theme
+ provides = spookyghost
+ conflicts = spookyghost
+ options = !strip
+ source = git://github.com/SpookyGhost2D/SpookyGhost
+ md5sums = SKIP
+
+pkgname = spookyghost-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..100f7464b685
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Angelo Theodorou <encelo@gmail.com>
+
+pkgname=spookyghost-git
+pkgver=r58.afb50fd
+pkgrel=1
+pkgdesc="A procedural sprite animation tool made with the nCine"
+arch=('i686' 'x86_64')
+url="https://encelo.itch.io/spookyghost"
+license=('MIT')
+depends=('glew' 'libpng' 'sdl2' 'lua' 'hicolor-icon-theme')
+makedepends=('git' 'cmake')
+conflicts=('spookyghost')
+provides=('spookyghost')
+options=(!strip)
+source=('git://github.com/SpookyGhost2D/SpookyGhost')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/SpookyGhost"
+ ( set -o pipefail
+ git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ git clone https://github.com/nCine/nCine || git -C nCine pull
+ git clone https://github.com/nCine/nCine-data || git -C nCine-data pull
+ git clone https://github.com/SpookyGhost2D/SpookyGhost-data || git -C SpookyGhost-data pull
+}
+
+build() {
+ cmake -S nCine -B nCine-build\
+ -DCMAKE_BUILD_TYPE=Release\
+ -DNCINE_DYNAMIC_LIBRARY=OFF\
+ -DIMGUI_VERSION_TAG=docking\
+ -DNCINE_PREFERRED_BACKEND=SDL2\
+ -DNCINE_WITH_THREADS=ON\
+ -DNCINE_WITH_WEBP=OFF\
+ -DNCINE_WITH_AUDIO=OFF\
+ -DNCINE_BUILD_TESTS=OFF
+ make -C nCine-build
+
+ mkdir -p build && cd build
+
+ cmake ../SpookyGhost\
+ -DCMAKE_BUILD_TYPE=Release\
+ -DnCine_DIR=$PWD/../nCine-build\
+ -DPACKAGE_BUILD_ANDROID=OFF\
+ -DPACKAGE_STRIP_BINARIES=ON\
+ -DPACKAGE_DEFAULT_DATA_DIR=/usr/share/spookyghost/data\
+ -DCMAKE_INSTALL_PREFIX=/usr\
+ -DCUSTOM_ITCHIO_BUILD=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR=$pkgdir PREFIX= install
+ install -Dm0644 $srcdir/SpookyGhost/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}