summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Jost2015-07-15 11:56:39 +0200
committerThomas Jost2015-07-15 11:56:39 +0200
commit1634ef27e939484cf89f44085d86619e6224ee68 (patch)
treebb59e6ed200f8804e9612306be010d227c7230ca
downloadaur-1634ef27e939484cf89f44085d86619e6224ee68.tar.gz
Import from AUR3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..861157467b89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spop-git
+ pkgdesc = A Spotify client running as a daemon, similar to mpd.
+ pkgver = 327.3890ab3
+ pkgrel = 1
+ url = https://github.com/Schnouki/spop
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = libspotify
+ source = git+https://github.com/Schnouki/spop.git
+ md5sums = SKIP
+
+pkgname = spop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9e35fcbc00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rasmus Steinke <rasi at xssn dot at>
+
+pkgname=spop-git
+_pkgname=spop
+pkgver=327.3890ab3
+pkgrel=1
+pkgdesc="A Spotify client running as a daemon, similar to mpd."
+arch=('i686' 'x86_64')
+url='https://github.com/Schnouki/spop'
+license=('GPL')
+depends=('libspotify')
+makedepends=('git' 'cmake')
+source=('git+https://github.com/Schnouki/spop.git')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cp -a ${_pkgname} ${_pkgname}-build
+ cd ${_pkgname}-build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=${pkgdir}/usr .
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-build
+ make DEST="${pkgdir}" install
+ install -D -m 644 ${srcdir}/${_pkgname-build}/spopd.conf.sample ${pkgdir}/usr/share/doc/spop/spopd.conf.sample
+}
+
+md5sums=('SKIP')