summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlongfin2015-10-20 20:03:36 +0900
committerlongfin2015-10-20 20:12:20 +0900
commit17fc978061f2f0e760863409b0e336383c85972d (patch)
treeedb502525385d110e0d2b5bf2a364f4250b6af1c
downloadaur-17fc978061f2f0e760863409b0e336383c85972d.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa459e36114e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = spoqa-han-sans
+ pkgdesc = TTF font for korean, english and japanese
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.spoqa-han-sans.com/
+ arch = any
+ license = sil
+ makedepends = tar
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/spoqa/spoqa-han-sans/archive/1.0.0.tar.gz
+ md5sums = ed6b47e9c28c3dd3893dfac2155ebfdf
+
+pkgname = spoqa-han-sans
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62399afa57c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e43b04bc2ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: longifn <longfinfunnel@gmail.com>
+
+pkgname=spoqa-han-sans
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='TTF font for korean, english and japanese'
+arch=('any')
+url="http://www.spoqa-han-sans.com/"
+license=('sil')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('tar')
+source=("https://github.com/spoqa/spoqa-han-sans/archive/$pkgver.tar.gz")
+md5sums=('ed6b47e9c28c3dd3893dfac2155ebfdf')
+
+
+build() {
+ cd $srcdir
+ tar xzf $pkgver.tar.gz "spoqa-han-sans-$pkgver/Original"
+}
+
+package() {
+ cd $pkgdir
+
+ install -d -m 755 usr/share/fonts/TTF || return 1
+ install -m 644 ${srcdir}/spoqa-han-sans-$pkgver/Original/**/*.ttf usr/share/fonts/TTF || return 1
+}