summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Still2016-04-19 10:19:09 +0200
committerVladimir Still2016-04-19 10:19:09 +0200
commit6a1642536cb2433845322f699a1d6fadf93b695b (patch)
treec865915071654dd637e9853de08914314079cb41
downloadaur-6a1642536cb2433845322f699a1d6fadf93b695b.tar.gz
Add spot.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a58ad783b39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spot
+ pkgdesc = Spot is a C++11 library for omega automata manipulation and model checking.
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://spot.lrde.epita.fr/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = glibc
+ depends = sh
+ depends = python
+ source = http://www.lrde.epita.fr/dload/spot/spot-2.0.tar.gz
+ sha256sums = 40ee69d8c7d9104d1474e64c8fc2361759715736067ba9c9bff5395a6b1a2192
+
+pkgname = spot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..485328d0ac5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Aaron Schaefer <aaron@elasticdog.com>
+
+pkgname=spot
+pkgver=2.0
+pkgrel=1
+pkgdesc="Spot is a C++11 library for omega automata manipulation and model checking."
+arch=('i686' 'x86_64')
+url="https://spot.lrde.epita.fr/index.html"
+license=('GPL3')
+depends=('glibc' 'sh' 'python')
+source=(http://www.lrde.epita.fr/dload/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('40ee69d8c7d9104d1474e64c8fc2361759715736067ba9c9bff5395a6b1a2192')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}