summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-07-31 13:57:42 +0200
committerDaniel Peukert2021-07-31 13:57:42 +0200
commita66e905ac913c1eacdd3e49414b1b94822022d76 (patch)
tree628a42094db35c19c25b9a279821cec3aba89031
parentaf3398d9f68d22d87b20958c034fb175cb3bb8e0 (diff)
downloadaur-a66e905ac913c1eacdd3e49414b1b94822022d76.tar.gz
Disable the spot-client Clippy test
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--disable-clippy-test.diff20
3 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 334c8a99571d..11b4c45103f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spot-client
pkgdesc = Gtk/Rust native Spotify client
pkgver = 0.1.15
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xou816/spot
arch = x86_64
arch = i686
@@ -20,7 +20,9 @@ pkgbase = spot-client
depends = libpulse
depends = openssl
optdepends = org.freedesktop.secrets
- source = spot-client-0.1.15-1.tar.gz::https://github.com/xou816/spot/archive/0.1.15.tar.gz
+ source = spot-client-0.1.15-2.tar.gz::https://github.com/xou816/spot/archive/0.1.15.tar.gz
+ source = disable-clippy-test.diff
sha256sums = 55fa29d3627b8e6218b6a0f927391887fbb1a496b597a74a3af70b75207f4121
+ sha256sums = ebf64746a9fff1242bdbf47736c78aaf7c3c94ef6423002662dbbb74db685004
pkgname = spot-client
diff --git a/PKGBUILD b/PKGBUILD
index 03a205c62147..ca2043234a39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_projectname='spot'
pkgname="$_projectname-client"
pkgver='0.1.15'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Gtk/Rust native Spotify client'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/xou816/$_projectname"
@@ -11,12 +11,23 @@ depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
optdepends=('org.freedesktop.secrets')
makedepends=('cargo' 'meson>=0.50.0')
checkdepends=('appstream-glib')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('55fa29d3627b8e6218b6a0f927391887fbb1a496b597a74a3af70b75207f4121')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ 'disable-clippy-test.diff'
+)
+sha256sums=('55fa29d3627b8e6218b6a0f927391887fbb1a496b597a74a3af70b75207f4121'
+ 'ebf64746a9fff1242bdbf47736c78aaf7c3c94ef6423002662dbbb74db685004')
_sourcedirectory="$_projectname-$pkgver"
_builddirectory='build'
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ # Disable Clippy test for now, as it still complains about some errors not yet fixed by upstream
+ # When reenabling, don't forget to use a patch to explicitly specify the Cargo.toml path (https://github.com/xou816/spot/issues/252#issuecomment-880941157)
+ patch --forward -p1 < '../disable-clippy-test.diff'
+}
+
build() {
cd "$srcdir/"
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \
diff --git a/disable-clippy-test.diff b/disable-clippy-test.diff
new file mode 100644
index 000000000000..f76738ec53ad
--- /dev/null
+++ b/disable-clippy-test.diff
@@ -0,0 +1,20 @@
+diff --git a/src/meson.build b/src/meson.build
+index 114c965..cbdfeff 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -185,14 +185,3 @@ test('Unit tests',
+ ],
+ timeout: 60
+ )
+-
+-cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
+-test('Clippy',
+- cargo_clippy,
+- args: [
+- meson.source_root(),
+- meson.build_root(),
+- get_option('offline') ? 'true' : 'false'
+- ],
+- timeout: 120
+-)
+\ No newline at end of file