summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-12-22 01:37:32 +0100
committerDaniel Peukert2021-12-22 01:37:32 +0100
commitf37597e6738d77a0845a2950a7a34d6b3738db29 (patch)
tree4b1e1e335eb2c6017eb9addca9c0b0829958b99f
parentddfec238c33c20f318c80bc47e4546963dba57fd (diff)
downloadaur-f37597e6738d77a0845a2950a7a34d6b3738db29.tar.gz
Fix failing Clippy tests for spot-client
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--clippy.diff10
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9509a7387b7..d73873dfd224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spot-client
pkgdesc = Gtk/Rust native Spotify client
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xou816/spot
arch = x86_64
arch = i686
@@ -24,7 +24,9 @@ pkgbase = spot-client
depends = openssl
depends = pango
optdepends = org.freedesktop.secrets
- source = spot-client-0.2.2-1.tar.gz::https://github.com/xou816/spot/archive/0.2.2.tar.gz
+ source = spot-client-0.2.2-2.tar.gz::https://github.com/xou816/spot/archive/0.2.2.tar.gz
+ source = clippy.diff
sha512sums = 997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a
+ sha512sums = 8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599
pkgname = spot-client
diff --git a/PKGBUILD b/PKGBUILD
index 0509d42b2295..fb213d7e46f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='spot'
pkgname="$_projectname-client"
pkgver='0.2.2'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Gtk/Rust native Spotify client'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/xou816/$_projectname"
@@ -12,13 +12,24 @@ depends=('alsa-lib' 'cairo' 'glib2' 'glibc' 'graphene' 'gtk4' 'libadwaita' 'libp
optdepends=('org.freedesktop.secrets')
makedepends=('cargo' 'meson>=0.50.0')
checkdepends=('appstream-glib')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ 'clippy.diff'
+)
+sha512sums=('997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a'
+ '8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599')
validpgpkeys=() # waiting for https://github.com/xou816/spot/issues/283
_sourcedirectory="$_projectname-$pkgver"
_builddirectory='build'
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Until they're fixed upstream, ignore some newly thrown errors from clippy 1.57
+ patch --forward -p1 < "$srcdir/clippy.diff"
+}
+
build() {
cd "$srcdir/"
# We're not using arch-meson, because upstream recommends using --buildtype 'release'
diff --git a/clippy.diff b/clippy.diff
new file mode 100644
index 000000000000..26b403fcef07
--- /dev/null
+++ b/clippy.diff
@@ -0,0 +1,10 @@
+diff --git a/build-aux/clippy.sh b/build-aux/clippy.sh
+index f60004b..22bdf6a 100644
+--- a/build-aux/clippy.sh
++++ b/build-aux/clippy.sh
+@@ -8,4 +8,4 @@ if [[ $OFFLINE = "true" ]]; then
+ export CARGO_HOME="$SRC"/cargo
+ fi
+
+-cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default
++cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default -A dead-code -A clippy::large-enum-variant -A clippy::redundant-closure -A clippy::derivable-impls