summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-03-14 09:34:13 +0100
committerDaniel Peukert2021-03-14 09:34:13 +0100
commit01a2dcdf1db7ae4fa76b2a520cc741c2fdb8ab1f (patch)
treebb6a9a72f3be6d6324e88c570f887a02d26643ce
parentfcb6d2b9f1a1b3212878158375ac80edb85d9106 (diff)
downloadaur-01a2dcdf1db7ae4fa76b2a520cc741c2fdb8ab1f.tar.gz
Update spot-client to 0.1.10
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17b64f37c31f..f13970d9e709 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
- pkgver = 0.1.8.r3.g68ce4b9
+ pkgver = 0.1.10.r0.g1d361b1
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = spot-client-git
depends = libhandy
depends = libpulse
depends = openssl
+ optdepends = org.freedesktop.secrets
provides = spot-client
conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot
diff --git a/PKGBUILD b/PKGBUILD
index dcbbb89d7147..323964a034f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='spot'
pkgname="$_projectname-client-git"
-pkgver='0.1.8.r3.g68ce4b9'
+pkgver='0.1.10.r0.g1d361b1'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -9,6 +9,7 @@ url="https://github.com/xou816/$_projectname"
license=('MIT')
depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
makedepends=('cargo' 'git' 'meson>=0.50.0')
+optdepends=('org.freedesktop.secrets')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
source=("$pkgname::git+$url")
@@ -24,7 +25,7 @@ pkgver() {
build() {
cd "$srcdir/"
- arch-meson "$_sourcedirectory" "$_builddirectory" -Doffline=false
+ arch-meson "$_sourcedirectory" "$_builddirectory" -Doffline=false -Dbuildtype=release
meson compile -C "$_builddirectory"
}