summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2021-07-31 14:27:24 +0200
committerDaniel Peukert2021-07-31 14:27:24 +0200
commitec2345ced4d70f17fab9db5767c52997e68dfea9 (patch)
tree0b052ba983b3b3167a4025c5c18a3e442f98eea9
parenta9ef7fdf5a8d6bacab1028de27b599c8897b0215 (diff)
downloadaur-ec2345ced4d70f17fab9db5767c52997e68dfea9.tar.gz
Remove Clippy test patch from spot-client-git, as it's been fixed upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--disable-clippy-test.diff20
3 files changed, 4 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 133956fdd2e3..0d4493e6fd09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
- pkgver = 0.1.15.r6.gac86fe7
+ pkgver = 0.1.15.r9.g6c66125
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64
@@ -24,8 +24,6 @@ pkgbase = spot-client-git
provides = spot-client
conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot
- source = disable-clippy-test.diff
sha256sums = SKIP
- sha256sums = 5420e171e7ba18bf1f7bcdfe02210aa9a5f24f416157e5a113d305864a2c4580
pkgname = spot-client-git
diff --git a/PKGBUILD b/PKGBUILD
index c7fa710c6414..2d0c62f7326a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='spot'
pkgname="$_projectname-client-git"
-pkgver='0.1.15.r6.gac86fe7'
+pkgver='0.1.15.r9.g6c66125'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -13,23 +13,12 @@ makedepends=('cargo' 'git' 'meson>=0.50.0')
checkdepends=('appstream-glib')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
-source=(
- "$pkgname::git+$url"
- 'disable-clippy-test.diff'
-)
-sha256sums=('SKIP'
- '5420e171e7ba18bf1f7bcdfe02210aa9a5f24f416157e5a113d305864a2c4580')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
_sourcedirectory="$pkgname"
_builddirectory='build'
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- # Disable Clippy test for now, as it still complains about some errors not yet fixed by upstream
- # When reenabling, don't forget to use a patch to explicitly specify the Cargo.toml path (https://github.com/xou816/spot/issues/252#issuecomment-880941157)
- patch --forward -p1 < '../disable-clippy-test.diff'
-}
-
pkgver() {
cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
diff --git a/disable-clippy-test.diff b/disable-clippy-test.diff
deleted file mode 100644
index 648551e119f1..000000000000
--- a/disable-clippy-test.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/src/meson.build b/src/meson.build
-index 829db1b..568d07b 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -185,14 +185,3 @@ test('Unit tests',
- ],
- timeout: 180
- )
--
--cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
--test('Clippy',
-- cargo_clippy,
-- args: [
-- meson.source_root(),
-- meson.build_root(),
-- get_option('offline') ? 'true' : 'false'
-- ],
-- timeout: 180
--)
-\ No newline at end of file