summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOle Jon Bjørkum2017-06-21 21:38:46 +0200
committerOle Jon Bjørkum2017-06-21 21:38:46 +0200
commit6174297558141ab575c64cfbb40f8a27b54f0dcd (patch)
tree8b3087f12d55f8c7c239be933e9d157e3291e0e2
parent39503f497c321c55e68f1677b9ba932389d14fd5 (diff)
downloadaur-6174297558141ab575c64cfbb40f8a27b54f0dcd.tar.gz
SpotCommander 13.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
-rw-r--r--spotcommander.install129
3 files changed, 18 insertions, 135 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81ce0a4ac14e..61e64e468ae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = spotcommander
pkgdesc = The most intuitive and feature-rich remote control for Spotify for Linux.
- pkgver = 13.1
+ pkgver = 13.3
pkgrel = 1
url = http://www.olejon.net/code/spotcommander
install = spotcommander.install
arch = any
license = GPL3
depends = apache
+ depends = inotify-tools
depends = php
depends = php-apache
depends = php-sqlite
+ depends = pulseaudio
+ depends = pulseaudio-alsa
+ depends = python2-xdg
depends = qt4
- depends = inotify-tools
- depends = xdotool
depends = xautomation
- depends = python2-xdg
- optdepends = pulseaudio
- optdepends = pulseaudio-alsa
- source = http://www.olejon.net/code/spotcommander/files/spotcommander-13.1.tar.bz2
- md5sums = 6776c4ae4d837a9ec64ba49ed58475f7
+ optdepends = spotify
+ source = http://www.olejon.net/code/spotcommander/files/spotcommander-13.3.tar.bz2
+ md5sums = 9913ebed94b82b573c4332f9a9e9a5cb
pkgname = spotcommander
diff --git a/PKGBUILD b/PKGBUILD
index 7a21305ca549..f3aa4938b5ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Ole Jon Bjørkum <mail at olejon dot net>
pkgname=spotcommander
-pkgver=13.1
+pkgver=13.3
pkgrel=1
pkgdesc="The most intuitive and feature-rich remote control for Spotify for Linux."
arch=('any')
url="http://www.olejon.net/code/spotcommander"
license=('GPL3')
-depends=('apache' 'php' 'php-apache' 'php-sqlite' 'qt4' 'inotify-tools' 'xdotool' 'xautomation' 'python2-xdg')
-optdepends=('pulseaudio' 'pulseaudio-alsa')
+depends=('apache' 'inotify-tools' 'php' 'php-apache' 'php-sqlite' 'pulseaudio' 'pulseaudio-alsa' 'python2-xdg' 'qt4' 'xautomation')
+optdepends=('spotify')
install=$pkgname.install
source=($url/files/$pkgname-$pkgver.tar.bz2)
-md5sums=('6776c4ae4d837a9ec64ba49ed58475f7')
+md5sums=('9913ebed94b82b573c4332f9a9e9a5cb')
package()
{
diff --git a/spotcommander.install b/spotcommander.install
index 9a84324548f5..791227f33426 100644
--- a/spotcommander.install
+++ b/spotcommander.install
@@ -1,118 +1,13 @@
post_install()
{
- echo "Configuring PHP..."
-
- sed -i 's/;extension=curl.so/extension=curl.so/' /etc/php/php.ini
- sed -i 's/;extension=pdo_sqlite.so/extension=pdo_sqlite.so/' /etc/php/php.ini
- sed -i 's/;extension=posix.so/extension=posix.so/' /etc/php/php.ini
- sed -i 's/;extension=sqlite3.so/extension=sqlite3.so/' /etc/php/php.ini
-
- echo "Configuring Apache..."
-
- sed -i 's/LoadModule mpm_event_module modules\/mod_mpm_event.so/#LoadModule mpm_event_module modules\/mod_mpm_event.so/' /etc/httpd/conf/httpd.conf
-
- echo -e "\n# Start SpotCommander configuration" >> /etc/httpd/conf/httpd.conf
- echo "LoadModule mpm_prefork_module modules/mod_mpm_prefork.so" >> /etc/httpd/conf/httpd.conf
- echo "LoadModule php7_module modules/libphp7.so" >> /etc/httpd/conf/httpd.conf
- echo "Include conf/extra/php7_module.conf" >> /etc/httpd/conf/httpd.conf
- echo "Include conf/extra/spotcommander.conf" >> /etc/httpd/conf/httpd.conf
- echo -e "# End SpotCommander configuration\n" >> /etc/httpd/conf/httpd.conf
-
- echo -e "Alias /spotcommander /usr/share/webapps/spotcommander\n\n<Directory \"/usr/share/webapps/spotcommander\">\nAllowOverride AuthConfig\nRequire all granted\n</Directory>" > /etc/httpd/conf/extra/spotcommander.conf
-
- systemctl enable httpd.service 1>/dev/null 2>&1
-
- systemctl restart httpd.service 1>/dev/null 2>&1
-
- echo "Creating symlink..."
-
- ln -s /usr/share/webapps/spotcommander/bin/spotcommander /usr/bin/spotcommander
-
- echo "Adding daemon to startup applications..."
-
- echo -e "[Desktop Entry]\nType=Application\nName=SpotCommander\nExec=spotcommander start" > /etc/xdg/autostart/spotcommander.desktop
echo "
--------------------------------------------------------------
| Installation complete! |
| |
- | YOU MUST NOW RE-LOGIN TO YOUR DESKTOP TO START THE DAEMON. |
- | |
- | You should then be able to control Spotify by going to: |
+ | GO TO THIS WEB PAGE TO COMPLETE THE INSTALLATION: |
| |
- | http://this.computers.ip.address.or.hostname/spotcommander |
- --------------------------------------------------------------
-"
-
-}
-
-pre_upgrade()
-{
- spotcommander stop
-
- echo "Backing up playlists and library in case of upgrade..."
-
- cp -p /usr/share/webapps/spotcommander/db/playlists.db /tmp/spotcommander-playlists.db
- cp -p /usr/share/webapps/spotcommander/db/library.db /tmp/spotcommander-library.db
-
- echo "Backing up Spotify authorization in case of upgrade..."
-
- cp -p /usr/share/webapps/spotcommander/run/spotify.country /tmp/spotcommander-spotify.country
- cp -p /usr/share/webapps/spotcommander/run/spotify.token /tmp/spotcommander-spotify.token
- cp -p /usr/share/webapps/spotcommander/run/spotify.username /tmp/spotcommander-spotify.username
-
- echo "Backing up authentication configuration in case of upgrade..."
-
- cp -p /usr/share/webapps/spotcommander/.htaccess /tmp/spotcommander-htaccess
- cp -p /usr/share/webapps/spotcommander/.htpasswd /tmp/spotcommander-htpasswd
-}
-
-post_upgrade()
-{
- if [ -e /tmp/spotcommander-playlists.db ]; then
-
- echo "Restoring playlists..."
-
- cp -p /tmp/spotcommander-playlists.db /usr/share/webapps/spotcommander/db/playlists.db
-
- fi
-
- if [ -e /tmp/spotcommander-library.db ]; then
-
- echo "Restoring library..."
-
- cp -p /tmp/spotcommander-library.db /usr/share/webapps/spotcommander/db/library.db
-
- fi
-
- if [ -e /tmp/spotcommander-spotify.token ]; then
-
- echo "Restoring Spotify authorization..."
-
- cp -p /tmp/spotcommander-spotify.country /usr/share/webapps/spotcommander/run/spotify.country
- cp -p /tmp/spotcommander-spotify.token /usr/share/webapps/spotcommander/run/spotify.token
- cp -p /tmp/spotcommander-spotify.username /usr/share/webapps/spotcommander/run/spotify.username
-
- fi
-
- if [ -e /tmp/spotcommander-htaccess ]; then
-
- echo "Restoring authentication configuration..."
-
- cp -p /tmp/spotcommander-htaccess /usr/share/webapps/spotcommander/.htaccess
- cp -p /tmp/spotcommander-htpasswd /usr/share/webapps/spotcommander/.htpasswd
-
- fi
-
-echo "
- --------------------------------------------------------------
- | Upgrade complete! |
- | |
- | YOU MUST NOW RE-LOGIN TO YOUR DESKTOP TO START THE DAEMON. |
- | |
- | You should then be able to control Spotify by going to: |
- | |
- | http://this.computers.ip.address.or.hostname/spotcommander |
+ | http://www.olejon.net/code/spotcommander/?install_from_aur |
--------------------------------------------------------------
"
@@ -121,21 +16,9 @@ echo "
pre_remove()
{
spotcommander stop
-
- echo "Deleting files..."
-
- rm -f /usr/share/webapps/spotcommander/run/daemon-user-*.socket
- rm /usr/bin/spotcommander
- rm /etc/httpd/conf/extra/spotcommander.conf
- rm /etc/xdg/autostart/spotcommander.desktop
-
- echo "Configuring Apache..."
-
- sed -i '/# Start SpotCommander configuration/,/# End SpotCommander configuration/d' /etc/httpd/conf/httpd.conf
- sed -i 's/#LoadModule mpm_event_module modules\/mod_mpm_event.so/LoadModule mpm_event_module modules\/mod_mpm_event.so/' /etc/httpd/conf/httpd.conf
-
- systemctl restart httpd.service 1>/dev/null 2>&1
-
- echo "Uninstallation complete!"
+ rm -f /usr/share/webapps/spotcommander/run/daemon-user-*.socket
+ rm -f /usr/bin/spotcommander
+ rm -f /etc/httpd/conf/extra/spotcommander.conf
+ rm -f /etc/xdg/autostart/spotcommander.desktop
}