summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2024-04-01 01:43:33 +0600
committerzoorat2024-04-01 01:43:33 +0600
commit3ba4a5eae19c37255369232b3e912123bacb708a (patch)
treea89cbeaa8fc4cd4468fbf5085b5332cdfc8c41fd
downloadaur-3ba4a5eae19c37255369232b3e912123bacb708a.tar.gz
renaming python-spotdl
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD73
3 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ace72488135
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = spotdl
+ pkgdesc = Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
+ pkgver = 4.2.5
+ pkgrel = 3
+ url = https://github.com/spotDL/spotify-downloader
+ arch = any
+ license = MIT
+ checkdepends = python-pytest-asyncio
+ checkdepends = python-pytest-mock
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry-core
+ depends = ffmpeg
+ depends = python
+ depends = python-bandcamp-api
+ depends = python-beautifulsoup4
+ depends = python-dacite
+ depends = python-demjson3
+ depends = python-fastapi
+ depends = python-mutagen
+ depends = python-platformdirs
+ depends = python-pydantic
+ depends = python-pykakasi
+ depends = python-pytube
+ depends = python-rapidfuzz
+ depends = python-requests
+ depends = python-rich
+ depends = python-soundcloud-v2
+ depends = python-slugify
+ depends = python-spotipy
+ depends = python-syncedlyrics
+ depends = python-typing-extensions
+ depends = python-ytmusicapi
+ depends = uvicorn
+ depends = yt-dlp
+ provides = spotdl
+ provides = python-spotdl
+ conflicts = python-spotdl
+ replaces = python-spotdl
+ source = https://files.pythonhosted.org/packages/source/s/spotdl/spotdl-4.2.5.tar.gz
+ b2sums = e7b1ba0c7bebceb0d78ea0b4974b7a2a46612f03a3b3e457f8f996d68b9b23df0c199448956ad5f4398effbe5d59d51c43c310f998a8d4798d07bb89f6c51a5d
+
+pkgname = spotdl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a85562a64ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: zoorat <zoorat [at] protonmail [dot] com>
+# Maintainer: Amin Vakil <info AT aminvakil DOT com>
+# Contributor: txtsd <aur.archlinux@ihavea.quest>
+# Contributor: Tim Schumacher <timschumi@gmx.de>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+
+pkgname=spotdl
+pkgver=4.2.5
+pkgrel=1
+
+pkgdesc='Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).'
+arch=('any')
+url='https://github.com/spotDL/spotify-downloader'
+# url='https://spotdl.readthedocs.io/en/latest/'
+license=('MIT')
+
+# https://github.com/spotDL/spotify-downloader/blob/master/pyproject.toml
+depends=(
+ 'ffmpeg'
+ 'python'
+ 'python-bandcamp-api'
+ 'python-beautifulsoup4'
+ 'python-dacite'
+ 'python-demjson3'
+ 'python-fastapi'
+ 'python-mutagen'
+ 'python-platformdirs'
+ 'python-pydantic'
+ 'python-pykakasi'
+ 'python-pytube'
+ 'python-rapidfuzz'
+ 'python-requests'
+ 'python-rich'
+ 'python-soundcloud-v2'
+ 'python-slugify'
+ 'python-spotipy'
+ 'python-syncedlyrics'
+ 'python-typing-extensions'
+ 'python-ytmusicapi'
+ 'uvicorn'
+ 'yt-dlp'
+)
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry-core')
+checkdepends=('python-pytest-asyncio' 'python-pytest-mock')
+provides=("$pkgname" 'python-spotdl')
+replaces=('python-spotdl')
+conflicts=('python-spotdl')
+
+# source=("https://github.com/spotDL/spotify-downloader/archive/refs/tags/v$pkgver.zip")
+source=("https://files.pythonhosted.org/packages/source/s/$pkgname/$pkgname-$pkgver.tar.gz")
+b2sums=('e7b1ba0c7bebceb0d78ea0b4974b7a2a46612f03a3b3e457f8f996d68b9b23df0c199448956ad5f4398effbe5d59d51c43c310f998a8d4798d07bb89f6c51a5d')
+
+# Document: https://wiki.archlinux.org/title/Python_package_guidelines
+build() {
+ # cd spotify-downloader-$pkgver
+ cd spotdl-$pkgver
+ # https://github.com/python-poetry/poetry/issues/5547
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ # cd spotify-downloader-$pkgver
+ cd spotdl-$pkgver
+ pytest || echo 'Tests failed! OR no tests.'
+}
+
+package() {
+ # cd spotify-downloader-$pkgver
+ cd spotdl-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}