summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryanLiang2023-11-23 00:22:02 +0800
committerBryanLiang2023-11-23 00:22:02 +0800
commit19600c1b172f8f08a1cfdd72617a2340568ad8a9 (patch)
tree993588519209be364739ffaf5d3160f37e799fac
parent8bcb8470d14223ebbb203c700f9acc9fa05d362f (diff)
downloadaur-19600c1b172f8f08a1cfdd72617a2340568ad8a9.tar.gz
Add desktop entry file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--spotifox.desktop9
3 files changed, 26 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a70dee9718e3..d1032ca5d898 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spotifox-bin
pkgdesc = Spotifox is yet another spotify CLI client similar to go-musicfox. (Precompiled version)
pkgver = 1.0.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/go-musicfox/spotifox
arch = x86_64
arch = aarch64
@@ -11,7 +11,11 @@ pkgbase = spotifox-bin
depends = alsa-lib
conflicts = spotifox
source = https://raw.githubusercontent.com/go-musicfox/spotifox/master/LICENSE
+ source = spotifox.png::https://raw.githubusercontent.com/go-musicfox/spotifox/master/previews/logo.png
+ source = spotifox.desktop
sha256sums = 20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54
+ sha256sums = c5be3b8375d0cff7661a7283c0e03b64f696059346a3441c79b41e28368aed24
+ sha256sums = d66c6c3ca65aa5e8e847a77cd9ae52ffa805944ab52305ebcbec61e4b093d839
source_x86_64 = https://github.com/go-musicfox/spotifox/releases/download/v1.0.2/spotifox_1.0.2_linux_amd64.zip
sha256sums_x86_64 = 23d3b1c97ce0407c7975b5bd5e8917e90486f52b50aa0b9c602658b6ea0fbba0
source_aarch64 = https://github.com/go-musicfox/spotifox/releases/download/v1.0.2/spotifox_1.0.2_linux_arm64.zip
diff --git a/PKGBUILD b/PKGBUILD
index 66bf60396996..33ac868e6af7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=spotifox-bin
pkgver=1.0.2
-pkgrel=3
+pkgrel=4
pkgdesc='Spotifox is yet another spotify CLI client similar to go-musicfox. (Precompiled version)'
arch=('x86_64' 'aarch64' 'armv7h')
url='https://github.com/go-musicfox/spotifox'
@@ -11,12 +11,16 @@ conflicts=('spotifox')
depends=('glibc'
'alsa-lib')
-source=('https://raw.githubusercontent.com/go-musicfox/spotifox/master/LICENSE')
+source=('https://raw.githubusercontent.com/go-musicfox/spotifox/master/LICENSE'
+ 'spotifox.png::https://raw.githubusercontent.com/go-musicfox/spotifox/master/previews/logo.png'
+ 'spotifox.desktop')
source_x86_64=("${url}/releases/download/v${pkgver}/spotifox_${pkgver}_linux_amd64.zip")
source_aarch64=("${url}/releases/download/v${pkgver}/spotifox_${pkgver}_linux_arm64.zip")
source_armv7h=("${url}/releases/download/v${pkgver}/spotifox_${pkgver}_linux_arm.zip")
-sha256sums=('20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54')
+sha256sums=('20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54'
+ 'c5be3b8375d0cff7661a7283c0e03b64f696059346a3441c79b41e28368aed24'
+ 'd66c6c3ca65aa5e8e847a77cd9ae52ffa805944ab52305ebcbec61e4b093d839')
sha256sums_x86_64=('23d3b1c97ce0407c7975b5bd5e8917e90486f52b50aa0b9c602658b6ea0fbba0')
sha256sums_aarch64=('062cfb2f7d6c14458fe08e9a5ac32b4041d021835ee313c41836fb0f1fd306cc')
sha256sums_armv7h=('5c15d13f3f75a72f9db3a815bac68b80379cf0917e86ecf411b7ea345fcf3461')
@@ -30,8 +34,10 @@ declare -A _archmap=(
_arch="${_archmap[${CARCH}]}"
package() {
- cd "${srcdir}/spotifox_${pkgver}_linux_${_arch}"
- install -Dm 755 spotifox -t "${pkgdir}/usr/bin/"
- cd ..
+ cd "${srcdir}"
+ install -Dm 755 "spotifox_${pkgver}_linux_${_arch}/spotifox" -t "${pkgdir}/usr/bin/"
+ # The real size of logo is 1024x1024, but some application launchers do not support that size.
+ install -Dm 644 spotifox.png -t "${pkgdir}/usr/share/icons/hicolor/512x512/apps"
+ install -Dm 644 spotifox.desktop -t "${pkgdir}/usr/share/applications"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/spotifox"
}
diff --git a/spotifox.desktop b/spotifox.desktop
new file mode 100644
index 000000000000..d71d150b2d31
--- /dev/null
+++ b/spotifox.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Spotifox
+Comment=Spotifox is yet another spotify CLI client similar to go-musicfox.
+Exec=spotifox
+Icon=spotifox
+Terminal=true
+Type=Application
+Categories=AudioVideo;