summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2017-05-26 03:13:45 +0100
committerAshley Whetter2017-05-26 03:13:45 +0100
commit6f913dbd73db905ea3c8672cf61724c5bef5093f (patch)
treef3cceabaf2ef39a433e09cc27c2db1cc3af78899
parent2af549d6be826d96322a0dbbe704c60d9efcf29a (diff)
downloadaur-6f913dbd73db905ea3c8672cf61724c5bef5093f.tar.gz
Using official openssl compatibility packages
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--spotify2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7de645480c91..9c4fd437df7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spotify
pkgdesc = A proprietary music streaming service
pkgver = 1.0.55.487
- pkgrel = 1
+ pkgrel = 2
url = http://www.spotify.com
arch = x86_64
arch = i686
@@ -15,8 +15,8 @@ pkgbase = spotify
depends = libxtst
depends = libx11
depends = libxss
- depends = libopenssl-1.0-compat
- depends = libcurl-openssl-1.0
+ depends = openssl-1.0
+ depends = libcurl-compat
depends = desktop-file-utils
depends = rtmpdump
optdepends = ffmpeg0.10: Adds support for playback of local files
@@ -26,7 +26,7 @@ pkgbase = spotify
source = spotify
source = spotify.protocol
source = LICENSE
- sha256sums = 12743e7f4338cc8d92d74bbeaedeeb0daf6bde496a9fd845663b45639920ff50
+ sha256sums = 989920e9360cadc1a8103b8c04acf0c87cb7911eb9a09dddb0cf4708d6249d34
sha256sums = af54f3b90cac46fa100b3f919a9225d10d847617d24aa9af3d832e7689f482c3
sha256sums = 4e8bea31ca27e16cac9c9dcd8f6ec27e1f82b45de86d6fee7a1e77e23f884b92
source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.55.487.g256699aa-16_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 25038efacd89..6c06b657d85a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=1.0.55.487
_anotherpkgver=.g256699aa
_amd64_pkgrel=16
_i386_pkgrel=16
-pkgrel=1
+pkgrel=2
pkgdesc="A proprietary music streaming service"
arch=('x86_64' 'i686')
license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
@@ -16,7 +16,7 @@ options=('!strip' '!upx')
source=('spotify'
'spotify.protocol'
'LICENSE')
-sha256sums=('12743e7f4338cc8d92d74bbeaedeeb0daf6bde496a9fd845663b45639920ff50'
+sha256sums=('989920e9360cadc1a8103b8c04acf0c87cb7911eb9a09dddb0cf4708d6249d34'
'af54f3b90cac46fa100b3f919a9225d10d847617d24aa9af3d832e7689f482c3'
'4e8bea31ca27e16cac9c9dcd8f6ec27e1f82b45de86d6fee7a1e77e23f884b92')
sha256sums_x86_64=('20073ba6fdf7d960361d4cb2afa6453e7a2108bd84df8f9cdf2cdf7225a83027')
@@ -26,7 +26,7 @@ source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spo
source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-${_i386_pkgrel}_i386.deb")
-depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "libopenssl-1.0-compat" "libcurl-openssl-1.0" "desktop-file-utils" "rtmpdump")
+depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "openssl-1.0" "libcurl-compat" "desktop-file-utils" "rtmpdump")
optdepends=('ffmpeg0.10: Adds support for playback of local files'
'zenity: Adds support for importing local files'
)
diff --git a/spotify b/spotify
index 8301e5ad2068..66466e2ed01f 100644
--- a/spotify
+++ b/spotify
@@ -1,3 +1,3 @@
#!/bin/sh
-export LD_PRELOAD="libcrypto-compat.so.1.0.0 libssl-compat.so.1.0.0 libcurl-openssl-1.0.so"
+export LD_PRELOAD=libcurl.so.3
/usr/share/spotify/spotify "$@"