summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxyzzy2018-12-14 15:05:50 +0100
committerxyzzy2018-12-14 15:05:50 +0100
commitb7f80c3bac53695ac929b5f7a118fcfeea6e211c (patch)
treecb111d43fd264427182c23ff829826fabd4cd1b3
downloadaur-b7f80c3bac53695ac929b5f7a118fcfeea6e211c.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rwxr-xr-xspotify-adblock.desktop11
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4d897d2531d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = spotify-adblock-git
+ pkgdesc = Adblocker for Spotify
+ pkgver = r2.ab860ef
+ pkgrel = 1
+ url = https://github.com/abba23/spotify-adblock-linux
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = spotify
+ provides = spotify-adblock
+ conflicts = spotify-adblock
+ source = spotify-adblock::git+https://github.com/abba23/spotify-adblock-linux.git
+ source = spotify-adblock.desktop
+ sha1sums = SKIP
+ sha1sums = 5240cf66c7a74c2d3733cf858c9cd78e033950a5
+
+pkgname = spotify-adblock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa313633e1f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: xyzzy <628208@gmail.com>
+
+pkgname=spotify-adblock-git
+_pkgname=${pkgname%-*}
+pkgver=r2.ab860ef
+pkgrel=1
+license=("GPL3")
+pkgdesc="Adblocker for Spotify"
+depends=("spotify")
+makedepends=("git")
+arch=("i686" "x86_64")
+provides=("spotify-adblock")
+conflicts=("spotify-adblock")
+url=https://github.com/abba23/spotify-adblock-linux
+source=(
+ "${_pkgname}::git+https://github.com/abba23/spotify-adblock-linux.git"
+ "${_pkgname}.desktop")
+
+sha1sums=(
+ 'SKIP'
+ '5240cf66c7a74c2d3733cf858c9cd78e033950a5')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd ${srcdir}
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm755 "${_pkgname}/${_pkgname}.so" "${pkgdir}/usr/lib/${_pkgname}.so"
+}
diff --git a/spotify-adblock.desktop b/spotify-adblock.desktop
new file mode 100755
index 000000000000..074ba5775a5b
--- /dev/null
+++ b/spotify-adblock.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=Spotify (adblock)
+GenericName=Music Player
+Icon=spotify-client
+TryExec=spotify
+Exec=env LD_PRELOAD=/usr/lib/spotify-adblock.so spotify %U
+Terminal=false
+MimeType=x-scheme-handler/spotify;
+Categories=Audio;Music;Player;AudioVideo;
+StartupWMClass=spotify