summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMageJohn2017-01-12 18:30:09 +0000
committerMageJohn2017-01-12 18:30:09 +0000
commitf8c6dcc6b94ae6867592bfb2f9f3e1746297edfd (patch)
treec1c04c9b218b420298c1b3f7b27981927ff33c57
downloadaur-f8c6dcc6b94ae6867592bfb2f9f3e1746297edfd.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
-rw-r--r--Spotify (dns-block).desktop12
-rwxr-xr-xspotify-adkiller-dns-block3
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..718a0d1d6c13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = spotify-adkiller-dns-block-git
+ pkgdesc = Experimental dns blocking from Spotify AdKiller
+ pkgver = r82.1184e1e
+ pkgrel = 1
+ url = https://github.com/SecUpwN/Spotify-AdKiller
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = spotify
+ provides = spotify-adkiller-dns-block
+ conflicts = spotify-adkiller-dns-block
+ source = git+https://github.com/SecUpwN/Spotify-AdKiller.git
+ source = spotify-adkiller-dns-block
+ source = Spotify (dns-block).desktop
+ sha512sums = SKIP
+ sha512sums = 31670a77b13d5a38dcfe96ccf5892996800b76d683071a46f27f647e353ad0e6adf95e3b2fbad9871f6296fc374fdb793d374d53cb5fd899949e694f5d579fab
+ sha512sums = 3a38a5634ef8fb82212f44b021b614bbad2682129ec21a5e90fd00fc60f66da025cb61a3960d7b16b12e7d54773bb3cc4f9c14b867febabb3e2cd232a7455686
+
+pkgname = spotify-adkiller-dns-block-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36d86882d3ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Yuri Pieters <magejohnyjtp at gmail dot com>
+
+pkgname=spotify-adkiller-dns-block-git
+pkgver=r82.1184e1e
+pkgrel=1
+pkgdesc='Experimental dns blocking from Spotify AdKiller'
+arch=('i686' 'x86_64')
+url=https://github.com/SecUpwN/Spotify-AdKiller
+license=('GPL3')
+depends=('spotify')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+$url.git"
+ "${pkgname%-git}"
+ "Spotify (dns-block).desktop")
+sha512sums=('SKIP'
+ '31670a77b13d5a38dcfe96ccf5892996800b76d683071a46f27f647e353ad0e6adf95e3b2fbad9871f6296fc374fdb793d374d53cb5fd899949e694f5d579fab'
+ '3a38a5634ef8fb82212f44b021b614bbad2682129ec21a5e90fd00fc60f66da025cb61a3960d7b16b12e7d54773bb3cc4f9c14b867febabb3e2cd232a7455686')
+
+pkgver() {
+ cd "${url##*/}"
+ git checkout -q dns-block
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${url##*/}"
+ git checkout -q dns-block
+}
+
+build() {
+ cd "${url##*/}"/experimental
+ make
+}
+
+package() {
+ install -D "${url##*/}"/experimental/dns-block.so -t "$pkgdir"/usr/lib/"${pkgname%-git}"/
+
+ install -D "${pkgname%-git}" -t "$pkgdir"/usr/bin/
+
+ install -D -m644 "Spotify (dns-block).desktop" -t "$pkgdir"/usr/share/applications/
+}
diff --git a/Spotify (dns-block).desktop b/Spotify (dns-block).desktop
new file mode 100644
index 000000000000..2ecba3a5fc1a
--- /dev/null
+++ b/Spotify (dns-block).desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Spotify (dns-block)
+GenericName=Music Player
+Comment=Listen to Spotify with experimental dns ad blocking
+Icon=spotify-client
+Exec=spotify-adkiller-dns-block
+TryExec=spotify
+Terminal=false
+Type=Application
+Categories=Audio;Music;Player;AudioVideo;
+MimeType=x-scheme-handler/spotify
+StartupWMClass=spotify
diff --git a/spotify-adkiller-dns-block b/spotify-adkiller-dns-block
new file mode 100755
index 000000000000..ba421a013961
--- /dev/null
+++ b/spotify-adkiller-dns-block
@@ -0,0 +1,3 @@
+#!/bin/sh
+export LD_PRELOAD=libcurl.so.3:/usr/lib/spotify-adkiller-dns-block/dns-block.so
+/usr/share/spotify/spotify "$@"